Errors following Excel and Data Tables Practice 1 - Calculating Sums

Attempting to follow along with Practice 1 of the module Excel and Data Tables. Got so far and needed to fall back to looking at the solution. The text for the solution is

I get to the last step in the solution which is using a Write Cell activity to update an existing Excel workbook/sheet. I am presented with an error:

Argument ‘Text’: Cannot implicitly convert type ‘double’ to ‘string’

Is there no way to tell the cell I’m writing general or a specific type of data?

To clear past this error, I added .ToString() on the sum. Fine. Not what I want, but whatever it takes to clear this practice.

I run the sequence and after the window minimizes, brings up Excel and then closes it, I’m presented with the final issue to deal with. Excel is in use. I have another instance of Excel (another worksheet) open, I close that. Same error. I restart Studio Pro. Same error. I completely reboot the machine, start Studio Pro, reload the project. Same error.

After this, I loaded up ProcessExplorer and fed it the file in question. It returned no matches for processes with the file already in use.

I’m really starting to not like this whole business of RPA…

Hi @rorourke
are u using the write cell under excel application scope ?

Yes. The practice specifically calls for doing so while Excel is open.

Can u use write cell under excel application scope rather than using workbook write cell activityimage

Since write cell based on workbook activity will open the excel instance too so it will cause error

to know more about the workbook and excel activities

use the documentation below

1 Like

Thanks. That’s what I was missing.

@rorourke Welcome to Community!

If your issue is resolved with the above comment then like the respective comment and mark the solution to close the open issue item.

Also, follow the same practice going forward. :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.