Error with Run Local Triggers in UiPath Form - Workflow Not Found

Hello UiPath Community,

I’m reaching out for assistance with an issue I’ve encountered in UiPath Studio related to UiPath Forms and the Run Local Triggers activity.

Issue Description: I am working on a project where I use UiPath Forms. Immediately after the Form activity, I have placed a Run Local Triggers activity. However, when I execute this sequence, I encounter the following error message:

Run Local Triggers: The .local\generated\Triggers.Generated.xaml workflow cannot be found. Make sure that it is part of the project.


Steps Taken:

  1. I have a UiPath Form activity set up.
  2. Right after the Form activity, I have added the Run Local Triggers activity.
  3. Upon running this sequence, the specified error is thrown.

Attempts to Resolve:

  • I have checked to ensure that all files are correctly placed in the project directory.
  • I have also tried rebuilding the project to see if the file gets generated, but to no avail.

I am not sure if I am missing a step in the setup or if there is a specific configuration that needs to be done for the Run Local Triggers activity to function correctly after a UiPath Form.

I would greatly appreciate any guidance or suggestions on how to resolve this issue. Has anyone else faced a similar problem, and how did you manage to solve it?

Thank you in advance for your help!

Best regards,
Stevan Lukic


Ideally trigger should be the first activity in the xaml



I’ve tried and when I put it as the first activity, then after I start the robot, it says that it is started and that it has started forms, but the form is completely empty. When I deactivate the activity “run local trigger”, then the form appears completely normal. Do you have any idea what could be there?