Error with Mail Folder when using Get Mail in Office 365 Scope

Hey guys,

I think I’m losing my mind. Finally managed to get office 365 scope working, but when using the Get Mail activity it throws an error “Invalid mail folder name. Please ensure that this folder exists and that its name is spelled correctly”.

The folder is of type “Inbox\Folder\Folder”, and it’s exactly the same as I had it with get outlook mail message activity, If I just use “Inbox” it works by getting the emails from my general Inbox, but I need to get the emails from a specific folder.

Any ideas? Thanks.

Please can you share a screenshot of the folder structure.

Hey, this the folder structure. I’m trying to read from the Input folder so I have my mail folder property as “Inbox\Unattended Process\Input Folder”.

27

I think there is some extra space in your folder name (Leading or trailing space).
Eg: “Input Folder SPACE”.
I tried a test this way and I got the error same as yours.
So, please ensure all leading and trailing spaces are removed (Or even if there are extra spaces in between the texts).

I checked there are no spaces. Also, the folder path I just copy pasted it from the get outlook mail message activity where it was working.

Sign in on iPhone

Please can I know, what is the activity you are trying to use?

UiPath.MicrosoftOffice365.Activities.Mail.GetMail

Any solution on this? Having the same issue.

Hi @Johan_Lundstrom ,
what is the folder path which you are trying to access?

I couldn’t find a solution for this. So I created my folders at the same level with the Inbox folder.

1 Like

Folder structure is as follows (trying to move to “Process 1”):

Robot

  • Inbox
  • Processes
    • Process 1

I can get/move mail from/to the same level as “Inbox”.

/Johan

Hi All,

On Monday (May 15 '20), we will release an update (v1.2.0) with support for subfolders in the Get Mail activity. Format will be “ParentFolder/Subfolder/AnotherSubfolder”.

2 Likes

Hello, this update is well received.