Error with HotKeys in Unattended

Hi All,

I am using hot keys in my process. But when i am trying to run bot in unattended mode, it is saying “System exception at initialization: Desktop has been disconnected while performing UI actions. at Source: Send Hotkey”.
And the RDP is not disconnecting, when i start the job from orchestrator.

Please help me with this

Assuming your hotkeys are not causing the disconnect (alt-F4 and such?):
Is your unattended bot running in UI mode or in Silent mode?

And, if the send hotkey fails, do other UI actions work? Clicks, get Text, etc…

Hot keys are not causing the disconnect. I am using win+r to open run from start.
Type into is working if i check send window messages.
what is meant by UI or Silent mode?

Hi @aditya ,

Sharing my thoughts on the issue you mentioned. long back we have faced the same issue.

Mostly this error would appear if the RDP disconnects for small amount of time.

Please check the below pints to resolve the issue.

  1. Set Login console to false in the orchestrator and try to run the process from orchestrator and see if it is working fine.

  2. May be this error occurs when a user is connected with RDP to the machine and the RDP disconnects at some point. We recommend to sign off all the users from the machines before executing a job.

If still not resolved we have to go some other ways like

  1. We can do some registry settings to avoid RDP window minimizing problem

(Running Tests in Minimized Remote Desktop Windows | TestComplete Documentation)


It is possible to run scripts without actually logging into windows. Top of mind it is called silent or stealth mode.
But, this only works if yo don’t actually have to start applications and perform actions that require user interface actions.

When you run attended/studio(x) scripts it is by default in UI mode, but unattended not per se…

I think in the current community condition it is this setting:
from your project → settings

The flag “Starts in Background”. Different Studio Versions might have it named different;ly though, I don’t recall (and have no access to my enterprise studio from here)

I’m not sure if this is the actual cause of your problem, but it is at least something to verify and rule out.

Hi @kirankumar.mahanthi1

I tried making login console to false and signing off all users, but it didn’t work

And i am trying to run in unattended mode, so what is the point of RDP window minimizing

Hi @Jeroen_van_Loon

I need to start few applications while running this process.
And i am using enterprise edition not community edition

Enterprise will have similar settings as community, I’m just not able to verify at the moment.

ok in your case please ignore the Third point. i am sharing the points which we have tried earlier. please try to use it if applicable to you.

Another point is if application got minimized hotkeys will not work. for hotkeys application should be in active state. otherwise try to use some activities to make sure application always on screen while using send hotkeys.


Hi @Jeroen_van_Loon

I am unable to identify the settings in enterprise edition