Error with arguments when using robot but not studio


Our organisation is new to using the robot program (been using studio to date) but I’ve encountered an issue with an invoked workflow that occurs without fail on the robot but not when the program is run from studio.

The error is “The following keys from the input dictionary do not map to arguments and must be removed”.

The argument given in the error message doesn’t actually exist either in the input arguments or within the invoked workflow.

I’m really stuck as I can’t remove an argument that already doesn’t exist! I’ve tried re-importing arguments within the parent workflow but this has not solved the issue.

I’d suggest deleting and remaking the invoke workflow activity abd then republishing the project.

Hi @SoqedHozi,

Once again Import(Not Edit argument) all the argument in your workflow.
And make sure you’re not leave any of the value as blank. And also check the arguments created by mistakenly.

If above are not working, then you have to Create new Invoke Workflow File activity and import the arguments as well.

Michael Udhaya

@SoqedHozi: whenever you try to make any changes in arguments do it by importing arguments as it will reflect the changes properly . For now in whichever workflows you are facing this issue , just do a import file and save . This should solve your problem

I’ve reimported arguments but no luck. I will try a new activity though I use these so often I hope I don’t have to do them all!

Tom Copeland​

Business Operations Analyst

Creating a new activity has worked, thank you!

Fingers crossed it’s just this case!

Tom Copeland​

Business Operations Analyst

1 Like