Error while uploading test automation package

Hello,
Please I keep having the error “an error has occured” while uploading a test automation package, does anyone have an idea what the problem is ?

This is a very general error and not much can be deciphered out of it.

  1. Are there any outdated packages in your project?
  2. Do you have permissions?
  3. If you check the Orchestrator logs, do you see any detailed error message?
  4. Next, did you try publishing to your Orchestrator directly from Studio?

thanks

Hi @Loha ,

As you are trying to publish test package, are you using studio pro or studio? Please note testing features only work from studio pro.
In addition, to be able to do this form studio pro, you will also need to set your test case as publishable by right clicking on it and selecting this option.

Once this done and you are still not able to publish, check your connection with test manager and role permissions assigned to you in orchestrator.

Hope this helps.

Regards
Sonali

hi,

thank you for the reply I did everything as you said :

  • I am using studio pro
  • the test case is set to publishable
  • I already established the connection to the testmanager and I am used to publishing packages

Hi,
Thank you for the reply.
I checked my packges they are not outdated and I do have permission to publish.
Can you please tell me how to publish directly from Studio to the Orchestrator ?

Hi @Loha,

Could you please share how are you trying to publish test package? I see you have attached orchestrator screenshot, are you trying to do it manually from orchestrator?
Have you tried to publish this from studiopro? Please check and let me know. Also will be good if you can share screenshots from studiopro as well if you face error.

Regards
Sonali

Yes I am manually publishing the package.
About directly publishing from studiopro, I am not sure how I can do it ?

Hi @Loha,

Its the same process as its done for any regular automation project.

Please use Publish option in studiopro for same.

Before that, please double check that test case is set as publishable as shown below:
image

Please follow these steps and let me know if you face any error(please share screenshot of the error as well).

Regards
Sonali

When you hit publish in studio, you have two options in the publish location. One is to save the package to your local drive and the other is to publish the package directly to the Orchestrator you are connected to. You can select this option to see if it works.

Hi @Loha ,

Also sharing below link for academy training on UiPath Test Suite, its really helpful:
https://academy.uipath.com/learningpath-detail/2234/3/0/3

Additionally below youtube link explains end-end demonstrations on what all required to be done.

Regards
Sonali