Error while Running unattended Robot on Virtual Machine at "CLICK activity" Its perfectly working when I am on the Virtual Machine and fails when I moved away from the Virtual machine

Hello Everyone, :blush:

  • About My process:

I have a process for Extract tables from “I-Query” add-in Excel.
In this process the robot need to open a new Excel tab, navigate to I-Query in Excel by some click activities then logon to database by username and password by Type into activities.
After that the robot should select specific tables and in every table should select some columns only by check activities, But the normal check/uncheck activity couldn’t deal with “I-Query app” interface so I had to use CV check activities inside CV scope to do that.
Finally, the robot save all those tables one by one in a specific folder on virtual machine after add the date of today to excel files’ names.

Now I need to run this robot every day to do the same process.

  • What I do to run this robot in Virtual Machine:

1- I run this robot on my PC a lot of times and it work perfectly without error.
2- I install uipath studio in VM and run the same workflow a lot of time in it, and also it work perfectly without error.
3- I connect this VM to Orchestrator and create a new machine with the same name of this machine in orchestrator and connect uipath assistant to orchestrator by machine Key which was generated by Orchestrator for this machine.
4- I schedule a trigger -for this process in shared folder at orchestrator- in a specific time every day and select that VM’s Robot to execute this process
5- When it’s time I was opening that VM by (Remot Desktop Connection) and the robot started and continue all process without any error.
6- In next day I was not opening the VM in (Remot Desktop Connection) but this machine is a server and it still running all time, but the robot fault at the first click activity in workflow with "Cannot find the UI element corresponding to this selector: " error message.

  • What I try to do to solve this problem:
    1- change the robot setting as login to console and but it NO
    2- change the resolution to 1920*1080 and depth to 32
    but it not working again. :pensive:
    3- changed normal click activities to Send Window messages from the properties and this activities work but the type into activities did not work even after I changed them to Send Window messages from the properties.
    and there are some normal click activities give me errors when I changed them to Send Window messages from the properties.
    4- I also tried Simulate Click and it didn’t work.

  • the main problem is there is no choice to change all CV activities to Send Window messages from the properties, So I don’t know if it possible to solve this problem or not.

Sorry for taking long, but I want to explain all thing to you to help me to find solution.

Best regards,
Bakr.