Error while Running the Robot at CLICK activity in Virtual Machine

Hello Everyone,

I have connected my Robot which in Virtual Machine to Orchestrator.

When I run the Job from Orchestrator Its unable to run the full process on the Virtual Machine, because the CLICK activity is unable to perform the action even the screen is virtually available on the screen.

I have tried with Simulate Click and also Send Window messages from the properties but no luck regarding this.

Its perfectly working when I am on the Virtual Machine and fails when I moved away from the Virtual machine.

The Virtual Machine is always running which never shutdowns.

Can anyone please help me how to resolve this?

Regards
Vishnu

hi @winningvish

please try the below, might work for you,

  1. use maximize window activity inside attach window for application.
  2. change the Robot setting as login to console ,

Regards
Ajay

2 Likes

Hi Ajay,

Thank you for your quick reply.

I have changed the Robot Settings as you suggested.

But the same error for the Click Activity : Time Out Reached.

Regards
Vishnu

@winningvish
Set the resolution as well (both width & height) and test.

if still not working then please remove simulate and send window message option and test the process

Regards
Ajay

Still No luck Ajay.

I have a doubt…Did Ui Automation Activities work even when we are away from the screen?

@lakshman would you please advise me on this?

Regards
Vishnu

Kindly try with SEND HOT KEY activity with key as tab to navigate along the fields and SEND HOT KEY activity with key as enter to click upon a field
Like how we do with keyboard with our using mouse

Cheers @winningvish

Hi @Palaniyappan

Thank you for your reply.

Unfortunately there are no key board short cuts.

But the Click Activity for the Button its worked perfectly.
Failed to click the menu Item as shown below.

Button


its worked when I am away from the Virtual machine
MenuItem

Clicking on menu Item failed when I am away from the screen.

What could be the reason for error? even I am using the same Click Activity with the same properties set.

Regards
Vishnu

To choose the drop down items we can use same SEND HOT KEY ACTIVITY with down as key so that it will select from the drop down
Like if we want the option which is in fourth spot of the drop down then use four Send HotKey activity with down as key so that once after reaching that option use a final send hot key with enter as key…
Same like how we do in keyboard
Or
If the drop down takes input by typing then once after reaching that folder type the input with TYPE INTO activity without selecting any element just type into activity with input string
Then a send hot key with enter as key

Cheers @winningvish

Understood @Palaniyappan.

I have tried with all possibilities to click on the Equipment Management using Hot Keys.

unfortunately the application does not have any keyboard Short Cuts to Enter into Equipment Management Menu Item.

once mouse click is performed I am using I am using Hot Keys to go to the next screen.

This process needs to be performed by UnAttended Robot in Virtual Machine. It seems there are more click activities already configured may fail the automation.

The Virtual Machine is available 24x7. But it seems the automation works only if the robot can see the windows to perform the actions? is my understanding is correct @Palaniyappan?

Regards
Vishnu

Yah but it’s not about the action and it purely about the virtual window is available to operate with maximised screen
Like are we having the studio and robot in our machine and trying to execute the process in a virtual machine by connecting from you local machine

Cheers @winningvish

I have Installed Studio and Robot in the Virtual Machine.

  1. Implemented the complete workflow in the Virtual Machine.

  2. Executed Successfully with out errors in the Virtual Machine

  3. Provisioned the Robot to Orchestrator Successfully.

  4. I came out of the Virtual Machine. (But VM is still running)

  5. Triggered the Robot from Orchestrator from the Local machine.

  6. Execution Successful for Click Button Activity

  7. Execution Faulted for Click Menu Item Activity Error:- (Click Menu Item Activity : Time Out Reached)

These are steps I have followed @Palaniyappan

Is it possible to resolve this error? @loginerror a bit confusing

Regards
Vishnu

Awesome
Yah it can be
Use a element exists activity before to the click activity
So that we can validate whether that element appeared or not by choosing that element with a selector using ELEMENT EXISTS activity And get the output with a variable of type Boolean
—now use a IF condition like
bool_exists = True
If true it will go to THEN part where we can have our click activity

Ensure that in element exists activity set the waitforready property as Complete
And in click activity as well
Along with that in click activity enable simulate click

Cheers @winningvish

1 Like

Sure @Palaniyappan

That would be great idea. Will check as advised.

Regards
Vishnu

No Luck @Palaniyappan

While Using the Simulate Click Property

While using Without Simulate Click Property