Error while Registering UIPath


Can anyone tell how to resolve the UIPath Registration error ‘There was an error trying to reach the activation server. You might be behind a firewall. Contact your System Admin’ while registering.

Are you behind a firewall ? a Company VPN most probably ?

Yes, I’m trying to register again on a Company’s system, but I already installed it previously and it was working fine but today I restarted the system and it is giving this error now, even I tried to reinstalled it many times.

check this for some known issues .

are you trying to activate Community edition or Licensed version ?

Community Version…

If you have already installed it previously , check for UIStudio.exe in AppData / Local folder

usually its at - C \Users<your user name>\AppData\Local\UiPath\UiStudio.exe ,

Create a Shortcut of this UiStudio.exe , and execute this to launch UIPath , it would not ask for License again if you have already installed it

It was working fine but after restarting the system it was again asking for the registration and I checked in the AppData/Local folder it was there and I ran from there as well but still got the same error. Then I deleted all the UI path Folders/Files and reinstalled but still no luck :frowning:

the first time you run the Community Editions .exe file , it installs UiPath Studio Community Edition in the AppData local folder , Once this is done , you shoudl not run the installer .exe … You should create a shortcut from AppData local folder on desk top and use that to start UIPath.

If the installer .exe is executed again , it wipes off the appdata local folder and treats it as a fresh install …

sadly once we run the installer .exe we would need to get registeration done via Online mode , and for that firewall shoudl no be blocking the License server mentioned in the above post :frowning: how did you get the license activated the first time ? maybe thats a way to try it again :slight_smile:

It worked now…Thanks for the support :slight_smile:

Welcome !!!