Error while Recording a Click on Oracle ERP

Hi,

Im facing following error while recording a click in Oracle ERP…

Click ‘A #’: Cannot find the UI element corresponding to this selector:

1 Like

Hi
welcome to uiapth community
kindly ensure once whether JAVA EXTENSION is installed
and SIMULATE CLICK property is enabled in the property panel of click activity
Cheers @Amit_Sharma

Thanks for response @Palaniyappan, Following package has been updated and simulate click is True but still issue persist…
Refer below Java Package and Error detail…

  1. Uipath.Java.Activities

  2. Click ‘A #’: Cannot find the UI element corresponding to this selector:

1 Like

No buddy
It’s not a package to be installed it’s a extension to be installed for JAVA APPLICATION
For more details on it

Once after installing ensure like when using click activity simulate click property is enabled
And if that does lint work either use
—SEND HOT KEY activity with key as tab to navigate across the fields and use n number of send hot key activity with tab key until we reach the field we want
—once after reaching the field we can use finally a send hot key with key as enter to make a click on that field
Like how we do the keyboard alone to navigate across the fields without using mouse

Or

—we can use CLICK IMAGE activity to click on it

Kindly try this and let know for any queries or clarification
Cheers @Amit_Sharma

@Palaniyappan, It would be great help if you can take system remote or if you could mail me your contact detail.

@Palaniyappan, After sending a Hotkey getting following Error…

"Send Hotkey ‘A #’: Cannot find the UI element corresponding to this selector: "

1 Like

Hi
kindly check once whether JAVA EXTENSION is installed or not
if installed we can use normal CLICK ACTIVITY itself with SIMULATE CLICK Property enabled
or
if the JAVA EXTENSION is not installed try with CLICK IMAGE activity
or
even that doesnt work use SEND HOT KEY ACTIVITY with key as tab and use n number of SEND HOT KEY Activit with tab key until it reaches the responsibility we need
and while using this send hot key dont select any element for selector just the hot key along
–and once after reaching the responsibility we need to get in use SEND HOT KEY activity with key as enter which will click on it

hope this would help you buddy
Cheers @Amit_Sharma

@Palaniyappan, Followed the steps recommended by you there are following observations…

  1. Program working perfectly fine when clicking on tab full after logging into the Oracle,There is no problem in the repetitive run also.
  2. But while clicking on the Responsibilities with help of Send Hot Key the first
    execution goes as per expectation and from the second run onwards program generated the below mentioned error…

1 Like

My contact detail is 7259101982

Hi @Amit_Sharma,
Have you tried Anchor base click?
Use Anchor base with Find element + click.

Thanks!

Kindly check once whether any dynamic value is there in selector
If there is any replace them with wild card *
To find that click in the same element once, get the selector and close the application and click again in the same and get the selector
Compare them so that we will come to know the dynamic value in selector
Cheers @Amit_Sharma

@Deepak94, I am getting following Error with Anchor based approach…

Hi @Amit_Sharma,
I think You are using it outside anchor base.
There is one activity Anchor base, inside that use find element and click activity.

Thanks!

@Deepa94, Tried Anchor Base following error popped up…

Error when achor base used within the loop…

@Deepak94 ,

Tried Anchor Base following error popped up…

1 Like

@Palaniyappan, Values are constant in selector…

1 Like

Anchor base activity can be used only when the element we need to click has a solid anchor element aside to it
Here we want to click on the Responsibilities which doesn’t have any solid element aside to it
So we can use Normal Click activity itself and that would work for sure
Unless it is in Citrix environment we don’t need to even SEND HOT KEY activity

—so while using click activity ensure that java extension is installed and only then we would be able to choose the elements as a individual element
—and while using click activity once after clicking and getting the selector go to edit selector wizard and click on OPEN UI EXPLORER where add few more attributes to it like aaname by enabling the checkbox in the rightside of the window
And also ensure that if any dynamic value is found along the selector like any attribute value changes from time being then replace those attribute with a wild card symbol *
So that the selector become so robust

And once this selector optimisation is done enable simulate click property so that it will be clicked even in the background

This would work for sure
Kindly try this and let know for any queries or clarification
Cheers @Amit_Sharma

Hi @Amit_Sharma

 Make sure the Java Extension is Properly installed or not.

 Better to Restart your system after installing it.

Try to use Element exists activity, and then a If condition to click that element.

@Palaniyappan, Thanks for your input, Issue fixed by introducing a delay in the sequence…