Error while contacting partition service to validate the organization (#503)


After upgrading the orchestratot from 20.10 to the latest version. I am not able to login to the orchestrator. All the robots were connected before upgrade are connected now and working fine. the only thing is I am not able to login. I am getting below error while login:

One thing different is in the login screen it asks for Organization name as below, previously we have only Tenant name:

Appreciate if anyone can help to fix it.


The orchestrator url you should be able to get it.I hope yours is cloud orch

Please check this

About organizations.


thanks for your replay. It is on-perm orchestrator


Then check with admin… or generally thats the name you would have given while configuring orchestrator…

When you are logged in …when you go to admin panel you can see the name in left menu above the tenants


Try this solution:

  1. Create a self-signed certificate on IIS.

  2. Export the self-signed certificate and deploy it to the client terminal.

  3. Binding the new self-signed certificate for the Orchestrator site on IIS.

Note: The old certificate is invalidated immediately after the binding update, so the robot can not work even if there is no site restart.

(※ The binding applies without restarting the site, but it is recommended to restart the site)

Step 2 is recommended to do first. The new and old self-signed certificates can coexist.

If a new certificate is deployed in advance, the robot can keep working after the binding update (if there is any problem, it needs to connect the robot to Orchestrator again)

Please refer to the following web guide for the detailed procedure: Using a Certificate for the HTTPS Protocol

@ahmedm Hello Ahmad, I am facing the same issue after the upgrade, did you find a solution?

Hi Mosa,

Please try this instruction if its still no luck

try this link

2nd link worked for me.

good luck.


1 Like

Hi together,

we got the same error “Error while contacting partition service to validate the organization (#503)” after updating the SSL certificate (had to be renewed). Data used in certificate is the same as before aside from new due date.
Binding in IIS as well as updated thumbprint for orchestrator (as described in guides above) was already done. Sadly there’s not much information out there for this specific error code/text.

Any other ideas how to fix this issue as nobody is able to login to orchestrator (website) anymore and robots can’t connect as well.

Kind regards

The issue is caused by the expired or not updated SSL certificate. More details about the encountered error you will see in the Event Viewer Application logs in your Orchestrator machine.

Check this article

After performing the above, restart both Orchestrator & Identity app services in Azure or in Orchestrator server open cmd.exe as Administrator, and run iisreset.