Error when training object detection - AI Center


I’ve tried to retrain the object detection model in AI Center but it always stops with an error.

I’ve followed this documentation: Object Detection

And used Imglbl to create the dataset.

Here’s the error message:

2021-02-01 15:00:33,006 - uipath_core.trainer_run:main:66 - INFO: Starting training job…
2021-02-01 15:00:35,479 - - INFO: Dataset from bucket folder training-8ea1d57b-9349-4752-be68-7d201c886cb5/ffff628b-c31e-469c-b858-56e7cdda5281/6bed5772-5936-4f2b-8e57-1ef7f1ff4b2f with size 24 downloaded successfully
2021-02-01 15:00:35,480 - uipath_core.training_plugin:train_model:104 - INFO: Start model training…
2021-02-01 15:00:35,480 - uipath_core.training_plugin:initialize_model:98 - INFO: Start model initialization…
2021-02-01 15:00:35,490 - root:init:37 - INFO: Finshed - Function Init : Partitioning done
2021-02-01 15:00:35,490 - uipath_core.training_plugin:initialize_model:101 - INFO: Model initialized successfully
2021-02-01 15:00:41,239 - root:load_yolo_weights:83 - INFO: conv2d_75
2021-02-01 15:00:41,239 - root:load_yolo_weights:90 - INFO: batch_normalization_72
2021-02-01 15:00:41,241 - uipath_core.training_plugin:model_run:140 - ERROR: Training failed for pipeline type: TRAIN_ONLY, error: No such layer: conv2d_75
2021-02-01 15:00:41,245 - uipath_core.trainer_run:main:81 - ERROR: Training Job failed, error: No such layer: conv2d_75
Traceback (most recent call last):
File “/home/aifabric/.local/lib/python3.6/site-packages/uipath_core/”, line 76, in main
File “/microservice/”, line 57, in run
return self.training_plugin.model_run()
File “/home/aifabric/.local/lib/python3.6/site-packages/uipath_core/”, line 141, in model_run
raise e
File “/home/aifabric/.local/lib/python3.6/site-packages/uipath_core/”, line 133, in model_run
File “/home/aifabric/.local/lib/python3.6/site-packages/uipath_core/”, line 202, in run_train_only
File “/home/aifabric/.local/lib/python3.6/site-packages/uipath_core/”, line 106, in train_model
File “/microservice/”, line 52, in train
File “/microservice/”, line 47, in main
load_yolo_weights(Darknet, Darknet_weights) # use darknet weights
File “/microservice/yolov3/”, line 104, in load_yolo_weights
conv_layer = model.get_layer(conv_layer_name)
File “/home/aifabric/.local/lib/python3.6/site-packages/tensorflow/python/keras/engine/”, line 563, in get_layer
raise ValueError('No such layer: ’ + name)
ValueError: No such layer: conv2d_75

Does anyone know what do do?


I have the same problem, did you already manage to fix it?

Hi Guys,
I would like to apologize for the very late response. I will reach to the team to figure out what might be the issue here. If any other details appeared since you posted this, please let us know.

@AntonMcG - could you take a look at it?

i got the same error

Hi @T0Bi,

I am trying to do the same and facing the same issue. Did you find a solution for it? If yes, do let me know about it.

Thank You.

Nope unfortunately not

1 Like