Error when starting xaml in command line

uiautomation

#1

I had to restart the PC and I’m trying to restart the xaml from the command line, but I’m getting an error message:
The process cannot access the file because it is being used by another process.

I tried closing UiRobot.exe from task manager, but it didn’t mane any difference. Actually it made the problem worse I think. I had to reinstall Uipath.

I tried also to use Process Explorer, but I don’t see any application using main.xaml.

From Process Explorer I see a list of processes when searching for uipath, but all seem to be related to UiRobot.exe

Any ideas on the best way to resolve this error?


#2

did you ever try to schedule the bot via “Task Scheduler”.I feel like u have created the new task and trying to run the “Main.xaml” file .

Could you please check are there any task created for that associated file.


#3

No, never tried the “Task Scheduler” previously


#4

@ddpadil , do you have any other suggestions? I’m getting mad trying to find a way to move forward on this

Thanks


#5

sorry mate :frowning: I don’t have any other suggestion to get rid of that error.
But all i know is you trying to schedule/run the specific .xaml workflow and your doing it via CMD.
As you said you never tried with “Task Scheduler” why don’t you give a try.
Please refer below link to do so.


#6

May be its the UiRobot.exe file itself having the conflict and not the Xaml?


#7

Thanks for the link. I just tried ‘Task Scheduler’ but I can not make it work. It is strange as I can see the status ‘Running’ but UiPath doesn’t really start.

I’m attaching the task. I’m not sure what I’m doing wrong

OnDemand.zip (1015 Bytes)


#8

before you run the scheduler have you publish the workflow?
and i can also see that workflow you attached in Xml format not in .Xaml.
Please attach the right one.
Thank you.


#9

@vvaidya, yes, I think you might be right. I tried to use other xaml files and I got the same error. I don’t know how to resolve this thought. I I close the process through ‘Task Manager’ I get another error message:

Also, if I try to start UiPath I get the following error message:

I need to reinstall UiPath to be able to open Uipath. Still, after reinstalling the cmd command is not working


#10

@ddpadil, I was using the xaml not a published workflow. I published the workflow and I created a new task in the ‘Task Scheduler’ but it didn’t work either.

The xml file I attached is the file created from the ‘Task Scheduler’ not the xaml workflow. I’ve sent the xml task so that you could see how the task was configured, in case I missed something there.


#11

@vvaidya, I tried also to use ‘handle.exe’ based on this article in StackOverflow, but it shows as not handles found


#12

No luck with ‘tasklist’ either:


#13

I’m not exactly sure @selrac. May be you should call you network guy and have him look into it.


#14

I found the problem:

I left the ‘c:>’ when I copied.:confused:

Hope it helps someone else