Error when running UiPathStudioSetup.exe


When I run the UiPathStudioSetup.exe file I keep getting the same error.


And when I click the “OK”-button this UiPath Studio Error:
“Object reference not set to an instance of an object.”

Does anybody know what I am doing wrong?:slight_smile:

Hello there,
Hi ,
Looks like your running .exe file every time which makes installer to overrides the AppData folder and starts UiPath Studio.
Try this.
navigate to %AppData\Local\UiPath\app-201*\UiStudio.exe or C\Program Files (x86)\UiPath Studio and create a shortcut on desktop and run from here.

Still same issue then
Try to delete the folder “UiPath” from %localappdata%, Or %programdatathen restart Studio.


Thank you so much for helping!

I tried both the things you described, and still got the same error.

The second solution, when you say restart studio, you mean unning the exe-file?

Here is the log:

not .exe . The shortcut you created on desktop.
Error say unable to find Uistudio.settings file. do you see any files by this name?

Ok. The shortcut on the exe-file on desktop didnt work either.

Here is the folder:


The UiStudio.settings file is there.

did you restart the system?
If nothing works its better reinstall it again.
Are you using 2018 edition?
If so i’ll tag this to post and QA team will take a look into this issue.

I think I am missing something. This is the process for me:

  1. I download the link I received on mail. which is “UiPathStudioSetup.exe”
  2. I run the “UiPathStudioSetup.exe”
  3. Then I get the error right away

I never get to click install.

ok .Do you mind checking .net framework in the system.
It’s recommended: 4.6.1

You can check software configuration here in case you need more in detail.

1 Like

I have 4.7.1 version of the .net framework.

ok thanks .

Please install this windows update package here and let me know how it goes.

IF still same issue then try this one (choose depends on your OS).

I hope either one should fix. If still same then will escalate further to concern team.

The first one is not applicable to the computer.

The second one is already installed:

found out it’s due to faulty windows update.
Try this.

One last try.
Hope this solves the issue. :smile:
amen :pray:

1 Like

It worked!! Thank you so much superman :smiley: Appreciate it! :raised_hands: