Error using Navigate to if location is a local file

activities

#1

If I open Browser (Chrome in this case) and use a file url the page is displayed as expected but if I then use the navigate to activity to move to a new file location it seems that the activity strips out the colon ( : ) after the file part of the url.

So for example file:/// becomes file/// and the page does not load

Here is the worflow:

and the result after the navigate to activity
image


#2

Hi bobpeers!

Did you tried to store the link in a variable?


#3

Im not sure, but i have tried this and it works well without the replace issue.(IE and Chrome)


#4

I’ve testing using a variable and it makes no difference, it doesn’t work. I also tried in IE and in this case none of the images load, not even the initial file:/// location in the Open Browser activity.


#5

Hi @bobpeers

Could you attach an example workflow (a simple open browser with the url)?

I have trouble reproducing it.


#6

Sure, it’s very simple._Test.xaml (5.8 KB)


#7

It works as expected (Studio 2018.4.0 beta + newest activity packs)
Could you add the versions of your Studio and of the activity packages? It might be that this issue was already found and fixed in the new version and it could potentially be resolved by updating your packages to the newest version.


#8

This is using activity version 18.2.6745.15248 on uiPath 2018.2.3