Error using Excel since Office was upgraded


We have several processes which use Excel to work off or write back to, and recently updated to Office 16. Since then, we keep getting “Exception from HRESULT: 0x800AC472” when running the process. It is opening the spreadsheet, but doesn’t seem to be able to read it. The spreadsheet also locks saying it’s already in use, but our IT department have confirmed it isn’t open on any sessions.

We’ve checked all the filepaths and they are correct. This has been happening across more than one process and we can’t find anything in the workflow to say why this is happening. The only thing we have changed in the process is the selectors since upgrading to the new Office.

Any ideas?

Hi, I found a solution to the same error. It might be that the excel is already opened. Try it and let me know if it worked or not.

Also, I recommend using the workbook activities. I always try to get away from using excel activities.

I’ve seen these sort of excel interaction issues since first using UiPath. I have always assumed some background reference to the file being open or already in use is logged and causes the error. I haven’t confirmed this as the workaround of adding a ‘Kill Process’ on excel before any Excel Application Scope has done the trick

Hi, thanks for your response. We’ve checked, and the file isn’t open. We wondered if it was open in another session but our IT department have confirmed it isn’t. I’ll try switching to workbook activities and see if that helps :slight_smile:

That’s a good idea. I will give it a go! Thanks.

1 Like