Error upgrading from 2019.10.18 to 2020.10 - missing Identity

Hi, we try to update our production orchestrator from 2019.10.18 to 2020.10. The installation wizard fails with “unexpected error” close to the end of the installation process. The log doesnt show a clear error cause.

The PlattformConfigurationTool shows the following error in the last of the pre-install checks:

Identity is not installed. Can not complete the Identity pre-installation checks.
Platform readiness validations: 7 succeeded, 1 failed and 0 warning(s).

On our test environment, we have already upgraded without issues.

It seems that the install wizard is looking for the identity module, but how can we install this or fix the issue? I´ve searched to re-install this to our 2019-10 version, but it looks like that Identity is bundled with Orchestrator. Re-Install of 2019-10 cant adjust the environment.
We´ve also tried to install 2020-04 first, but it leads to the same issue.

Are there any hints, how can we achieve the installation of Identity and get rid of this error?

PlatformConfigtool

Thanks and best regards
David

HI @David_van_den_Breul - Plese verify all the
pre-req - https://docs.uipath.com/installation-and-upgrade/docs/orchestrator-prerequisites-for-installation
Upgrade considerations - https://docs.uipath.com/installation-and-upgrade/docs/installation-considerations
Follow the steps - https://docs.uipath.com/installation-and-upgrade/docs/updating-using-the-windows-installer

if you still have issues, please reach out to our Tech support team.

Solved it - for whom it may concerns: We had the windows firewall service deactivated. This leads to a installation error quite close to the end of the installation. By installing an old version (2020.4) and using the manual log-feature ( /l*vx <LogFile>) we could see, that this was the error. The firewall service needs to be running during the installation.

Best regards
David

@David_van_den_Breul - Hi David, hope you are aware there is no Identity Server concept in 19.10 as it came into existence with 20.4 onwards. Since there is no Identity Server, the configuration tool gave you the above error which is not an error when it comes to upgrade from 19.10 to 20.x. Just attaching the different scenarios for your reference when tried with Configuration Tool. As you have mentioned above, actual installation might have failed due to firewall issue but the platform configuration error with Identity Server is expected when it comes to 19.10 or lower versions. Hope this gives some additional insights.

Configuration tool with 19.10.x :


Configuration tool with 20.4.x :

Configuration tool with 20.10.x :

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.