Error upgrading Android Studio after UIPath installed

studio
error

#1

Hello there, I recently installed UIPath on the Windows host that I am using for development tasks. I was performing one of my weekly activities - scanning for and updating software when I encountered an issue upgrading Android Studio to the latest version (3.3 to 3.3.1.) Oddly the errors pertain to UIPath

The Android Studio updater downloads the patch file, validates the installation and fails on 2 unexpected files jre/jre/lib/ext/UIPathBridge.jar and jre/jre/bin/UIPathJavaBridgeV8_x64.dll

I tried uninstalling UIPath but it hadn’t cleaned up properly so I cleaned up all remaining traces, rebooted etc and a cold boot. The issue recurred and when I searched the file system I found these files in the Android Studio version’s temporary folder within my user home drive under C:\Users\USERNAME.AndroidStudio3.3\system\tmp\patch-update\jre\bin

I had installed the Java Extensions and I know the error messages I got there when enabling them was due to having later Java versions that aren’t supported by the Java Extensions.

I have licensed versions of IntelliJ Idea and PyCharm and had no issues updating those. I am just curious if anyone else has encountered a similar issue updating Android Studio on a system that has UIPath Studio installed.

I have not tried uninstalling/reinstalling Android Studio as yet (I didn’t want to go through blowing all that away if I could help it.)

Thank you
GS