Error: SetNextActivity::child

Hello everybody,
I’ve been facing this error multiple times now and I can’t find anything about it.
It happens randomly on any activity and makes the whole workflow not being able to be run because if the error is there and I press “run” or “debug” the activities within the workflow are being executed randomly.
I can’t figure out what causes it and how to get rid of it. The only workaround I found working is to create a new sequence and copy/paste all the activites one by one and look if the error occurs when I press “run from this activity”.
It looks to my as if there is some information missing in which order the activities are supposed to be run.

Below is a screenshot and the Error Log. I am using Studio Version 2021.10.4. I hope you guys and girl can help me, since this is slowing down my development tremendously.
Thanks in advance!


SetNextActivity::child with id 1.50 not found on container 1.3

RemoteException wrapping System.InvalidOperationException: SetNextActivity::child with id 1.50 not found on container 1.3 
   at UiPath.Executor.Debugger.FlowControl.JumpToChild.GenericSequenceJumpHandlerBase.SetStartActivity(String childId)
   at UiPath.Executor.Debugger.FlowControl.JumpToChild.JumpHandlerFactory.Create(IActivityScheduledRecord record, String childId)
   at UiPath.Executor.Debugger.FlowControl.FlowControlService.HandleJumpToChild(IActivityScheduledRecord record, JumpToChildActivity jumpAction)
   at UiPath.Executor.Debugger.FlowControl.FlowControlService.HandleTrack(IActivityScheduledRecord record)
   at UiPath.Executor.Tracking.DebugTrackingParticipant.OnTrack(TrackingRecord record, TimeSpan timeout)
   at UiPath.Executor.Plugin.Api.SynchronizedTrackingParticipant.Track(TrackingRecord record, TimeSpan timeout)


Hello @Armin_Muller ,

Have you tried to set the correct xaml which is supposed to run first as main? Like this:


I’m using the REFramework so the Main.xml is set to Main.

Hi @Armin_Muller ,

We would like to know if the issue was Solved when you Copy Pasted the Activities into a New Sequence.

If it was solved and you would want to know the cause, Could you provide the Sequence which was giving out the Error and the Sequence which is working after Copy/Paste.

Hi Arpan,
the issue is not solved if I copy/paste the activities.
In order to get it working. I have to make a new sequence and copy/paste every activity one by one and check after each paste if its working. After I found the error-causing activity, I redo the activity from scratch.

Hi @Armin_Muller

Would you mind sharing a sample project that reproduces the issue (even if it is a dummy one)?

Is it always the same activity that causes the issue, or any at seemingly random?

Also, does upgrading activity package of the faulty activities help you resolve the issue?

@Armin_Muller Is to possible to provide that Error xaml file ?

You could also Try the Below Approach :

  1. Copy the File which gives the Error into a New Project Folder.

  2. Open the xaml file from the new Folder.

  3. Install any Dependencies if it gives out Package Missing Error.

  4. Check if the same problem Persists by Executing.

Hi loginerror,

I will have to change a fewthings so there is no customer related data, but I will upload ASAP.

For my eye the occurance is completely random.

Upgrading the packages is not working. They are all up to date.

1 Like

Hi Loginerror,

I think the problem is within the project.
If I copy a error-causing workflow and open it seperately it is working just fine.

Reproducing the error is time consuming since it happens completely random.

Here are two identical workflow with the difference, that the not working one has one extra activity which is causing the error.
Sequence_notWorking.xaml (52.1 KB)
Sequence_working.xaml (49.9 KB)

I see. In that case, any chance you could share a zip of the whole project, or at least the project.json file?

My collegue and me have the same error. Would be interesting to know what causes this. For us, the workflow runs fine if we run it completely, but when we try to start the WF from a specific activity this error is thrown…makes debugging so much fun.