Error on Send Exchange Mail Message on XML Response

email
activities
p_solved
exchange

#1

It says me this on the output error:

“Send Exchange Mail Message : The response received from the service didn’t contain valid XML.”

And also sends this error:

Any idea? Thanks!


#2

Can you upload a screenshot with your parameters? Please note to hide the password.


#3

Sure;

And by the way; sending a mail from the web app: https://owa.stcapital.cl/owa works with those credentials perfectly. So i assume is something on the response parser or something like that. Thanks!


#4

for server : try this "https://YOURSERVERFQDN/ews/exchange.asmx"
for user, add the whole email server : user@YOURSERVERFQDN


Send exchange mail activity - 'Send from' does nothing
Unable to connect to Exchange account
#5

Hey!, with only that server config change works!..thanks a lot!


#6

@ovi please pin this thread


#7

The only detail, maybe you know what’s happening.
For some reason, the mails send with this way doesn’t appear on the “sent folder” on my exchange web interface.
Do you know where can they be, i need them as a backup.


#8

interesting, we can investigate why is this happening, maybe we can “fix” it


#9

Would be nice, thanks.

Adding to this “mystery”, when a email is not send by an error (like incorrect receiver mail format); that mail does appear on the draft folder.


#10

can you try the SaveCopy checkbox from Options? that one should save the email in Sent


#11

Yei!, that was it. Thanks!


#12

I have tried with all possible recommended options to give server entries but still no luck, Please help below are my details:-
Options Tried:-
1: Server: "https://192.168.77.222/ews/exchange.asmx/"
2. Server: "https://192.168.77.222/owa "

Error Message

If I directly try to access the https://192.168.77.222/ews/exchange.asmx/ after giving user name and password I get below page

If I Try to access the link directly “https://192.168.77.222/owa” I will get below page

My UIPath exhange setting below:-1:
image

Please help none of the options are working.


#13

For some reason (parsing message error) the error you screenshot doesn’t have the correct error message, look at the Output info Error detail and told us what it is? (send that screenshot)

For me, their was an error about ssl certificates i have to solve first.


#14

Hi GERMAN_LARRAIN,

Please find below screenshot for value 1: Server: “https://192.168.77.222/ews/exchange.asmx/

Please find below screenshot for value 2. Server: "https://192.168.77.222/owa "

I dont think, it is related to certificate as in browser is shows not secure as below


#15

Hi; you don’t get what i need to see, this is where the output message error should be:

Send it.