Error on nested Invoke Workflow activity

Hi.

I’ve built a Flow (a) that Invokes another Flow (b), which also Invokes another Flow ©.

The problem is that:
When I run Flow© via Flow (b) or run Flow ©alone, no errors occur.
However, when I run a Flow © via Flow (b) via Flow(a), Flow © throws an error.

Is it impossible to nest Invoke Workflow activity?
Is there anyone who knows how to fix it?

@ynnn - Are you passing any arguments to your invoke workflow activity ?

If yes then probably it well work only if you execute that flow in sequence order you have invoked.

Yes, I’m passing arguments to Flow (b.) and to Flow(c.).

I’m sorry. I don’t understand following sentence…

@ynnn - Then it will work only in sequence order with your code.

Suppose you have written like A => B=> C=>D then will work in sequence from A=>D
as you have passed some arguments to sequence.

@ynnn, It is possible to nest invoke workflow activity. Can you please share error detail?

Okay, I understood.
You mean I can’t nest Invoke Workflow activity when I’m passing arguments to the workflow.
But I’m just wondering why it throws an error where arguments are not related…

Anyway, Thank you for your answering.

@Bhavik_Solanki
Is that possible to nest invoke workflow activity passing arguments?

An error is just selector error.
I’m sorry but I correct Error activity; it was “Type Into”.

Error message is “UI element not found”
(This is not perfect quote because it’s in Japanese in the log)

Yes, you can.

The error suggests that there is an issue with workflow. When it executes Type Into activity it is not able to find an element on UI. I think you should debug and ensure that the expected webpage/UI is available and also specific element is available on UI.

@Bhavik_Solanki

Yes, I know. I did debug and ensure the expected UI is available several times.
And, I can execute Flow (C ) alone with no errors.
But I I can’t do it only when Flow (C ) is via Flow (B ) which is via Flow(A )…

After all, I changed selector, then the problem’s been resolved.

But the fact remains that the error occurs only when the flow is executed via nested invoke workflow and I’m still wondering… if anyone knows, please tell me why.

Just for reference, selectors are like this;
キャプチャ
@Bhavik_Solanki
@sandipauti
Thanks a lot!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.