Error on dropdown with Click/Select Item

Hi,

I have encountered this problem:
I have a SW that I have to open and then I have to login.
To login the SW has a dropdown list, I have to click on the correct username.
image

When I move the select item to the beginning of the process and open the SW manually, it works correctly.
When I move the select item after open application I get the error: "“Select Item ‘ComboBox’: Error HRESULT E_FAIL has been returned from a call to a COM component”.

I tried to use the click, replacing the select item.
If the click is placed at the beginning, it works correctly. If the click is placed after “open application” it works but when I click it I can’t find the word.
image

How can I solve this problem?

thank you for your attention,
Edoardo

Hi,
If it is editable use Type into activity and enter the value “SW” directly.
If not Set Focus on drop down and use no of keydowns until select the SW using send hotkey activity and enter with send hotkey.

2 Likes

I can’t use Type Into because it’s a dropdown list, it doesn’t make me write.
The Focus set is not working.
I tried to insert it both before and after the open application and found nothing.
The error that is generated for all activities: select item, click and Set Focus, is that if I put it after the “application scope” when they try to search for the value, it disappears in the dropdown list. While, if I open the SW manually (excluding the focus set) they find the value.