Error on connect Robot to Orchestrator

I am using Uipath in virtual box (Windows 10) since my OS is Mac OS. I had created machine, robot and environment. In Uipath Robot, when I tried connecting Robot to Orchestrator, I am getting error as “Invalid Machine Key”. Tried multiple times but getting the same error.I am attaching the screenshots for reference.sn2error

Please make sure that

a) You’ve created a Standard Machine with a machine name matching that of the hostname your Robot service is running on

or

b) You’ve create a Machine Template

Then make sure that you’ve copied the machine key and pasted it into your UiPath Robot’s Orchestrator Settings along with the correct Orchestrator URL for your instance.

What version of UiPath do you have installed for your Robot? From the screenshot I would guess 19.10.4 or lower running UiPath Robot or Agent Desktop.

The error message is implying that the machine key you typed in does not exist in Orchestrator (it will be accepted even if the machine name didn’t match) or you have a typo)

1 Like