Error: Object referance not set to an instance of an object

Hi ppl,

So I am working on the Foundation training and on lesson 7 practice 1 I have to use Image Recording - Click Text on this Email label on the Expense app when I do and the Screen Scraping Wizard appears and I navigate to Search Text and type in Email, then proced to click Set Mouse Position, I am greated by this error : Object referance not set to an instance of an object.

What could be the cause of it?

Also, the screen scraping wizard doesnt seem to read any text from the label i selected.
I tried and changed the Scraping Method and the OCR Engine but got the same error, then switched them again acording to the statement in the practice exercise, still failed.
I added a printscreen.


1 Like

Hi @Gaki,
I see you have old version of Studio. Please try with newest version if the problem is the same.

Hi @Pablito,

i’m pretty sure i don’t have an old version, as my studio comm edition has updated recently, i think almost 2 months ago.
i would’ve added a snippet to clarify, but it seems that i can’t do this in replies. my version is 2019.7.0


I see you have no language chosen in your Scraping Wizard. Please set one and will see. I tested this on the same application from this exercise and all works fine.

In the newest version 2019.8.0 I fixed this by using “Tesseract OCR” instead of “Microsoft OCR” that the exercise instructed. This gave me the language and click options that are expected.

Hope it helps someone.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.