ERROR Notes error: Could not open the ID file -Email automation with Lotus Notus

Hi iam trying to use the new activities for lotus notes but i am stuck with this error.

19.5.0-beta.60+Branch.release/v2019.5.0.Sha.da9a85cc143e242aa2ac0bce03286c7ffdadb26c

Source: Send IBM Notes Mail Message

Message: Notes error: Could not open the ID file.

Exception Type: System.Runtime.InteropServices.COMException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Runtime.InteropServices.COMException: Notes error: Could not open the ID file
at UiPath.Mail.Activities.SendMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I tried some tips on this forum like execute note with =C:…(path of notes.ini),
but if no sucess.

My notes version is 9 and path if notes.ini location in another driver

Hi @franciscojunior

Welcome to our UiPath Forum! :slight_smile:
Could you post a screenshot of how it is configured for you right now?

Could you also switch to the Stable 2019.5.0 version, just in case :slight_smile:

I switched to beta just for try solve my problem.:grinning:

Solved just putting my notes.ini and .ID in same folder of .exe of lotus

Hi @franciscojunior,
Lotus ID file is strictly related to user and his lotus profile. Studio activities for lotus are based on default application construction where ID file is located (as you discovered) in the same folder where .exe file is. We had very similar topic:


User was able to resolve the problem by changing registry entry for .ini file. But it is worth to remember that the best solution is to having everything in same folder.

Hi Pablito,
I have a special problem regarding notes mailactivities: In our network-environment the notes client and so the notes-id is not stored on the local machine but on a server which is connected via citrix. We are able to use the notes in this citrix-connection (with the remote-runtime.exe) but can I define in the activities, that my notes id is not local?
I tested it with Studio 2019.4.4 and mail.activities 1.5.0 and got the error “ID file could not be opened”.
Thanks for your help!
Moritz

Hi @mm1904,
I was working a little with Lotus distributed through citrix. The problem is that those activities are made for potential local use. I’m not 100% sure but maybe proper lotus folder redirection in citrix could fix this. The folder could be mapped on your local computer using citrix policies so activity could see it as it’s local. But I’m not sure if it will work.

2 Likes

Hi @Pablito,
thanks for your informations! I will discuss this issue with our network-admin, if their can redirect folders as you told.
It worked in our network to send mails with the ‘send SMTP Mail Message’ activity, the admin allowed the robot-machine to logon directly to the notes server. But now they are a little bit scared about a robot being logged on to the server…
Maybe the folder redirection ist the better way.

Moritz

2 Likes