Error message Read Cell Workbook: The process cannot access the file 'filename' because it is being used by another process

I tried to do UiPath Academy (Building the workflow Part Two).
First: activity “read cell” does not exist anymore, only “read cell value exists” (and requires an additional parameter). Not so good. Could you please update the academy?

Second: when using “read cell value” I do get the error message ‘Read Cell Workbook: The process cannot access the file ‘.\Invoices\Invoice 4.xlsx’ because it is being used by another process.’

What can I do to get rid of this error to be able to continue my first automation with UiPath?

Many thanks in advance for hint that help to solve my issue.
Kind regards

Hi @stefan.roell ,
please use read cell activity instead of using read cell workbook activity



Thanks for your reply.

As i wrote: “read cell” is NOT available. Only “read cell value” or “read cell workbook” is available.

Since “read cell” is NOT available, i tried both “read cell value” and “read cell workbook”, result always was the same error message.

Hello again,

in case it is relevant: i am using the UiPath community edition.

Hi @stefan.roell

you are doing in the bad way, if you are using excel applications scope, you can´t use the workbook activities, so please remove the workbook activity and replace for an read cell, if you dont have it go to your filter and click on show classic


the second way is deleting the excel application scope activity and just use the read cell workbook activity