Error message: 'Permission missing: Launcher' - any ideas?

I had to remove all traces of UIPath on my machine, once I did think I was able to install again and it worked. No idea what the problem was though

1 Like

This got resolved by reinstalling the trial version again.Seems something related to different versions being installed in my desktop.Thanks for the response guys :slight_smile:

1 Like

Do we need to reinstall software for data conversion errors? Is it a bug or code issue?

1 Like

What’s the error message ?

1 Like

Error message: ‘Permission missing: Launcher’
Unable to access excel files, I have administrator account in my laptop but unable to access files from UiPath

1 Like

‘Permission missing: Launcher’ error is received in the following scenario:

  • robot is connected to orchestrator with user “abc”
  • on the robot machine you try to start robot (from tray or studio) with user “admin”

Let me know if you have other questions.

1 Like

I had exactly this issue. It was caused by my community license needing renewing so I just restarted UiPath and followed the instructions to renew. Works fine again.

2 Likes

To avoid licensing problems just use deactivate from regutil and reconnect to orchestrator. Here are more details: https://robot.uipath.com/v2017.1/docs/regutil-command-descriptions

Note: Keep in mind that SVC restart is required !

1 Like

Facing the same issue. But once i restart my machine, it starts working fine.
But same error appears after sometime.

Is there any limitation of hits or number of run in community edition??
Please suggest what to do

Thanks in advance

1 Like

I am using UiPath Community Edition and i dont have the Orchestrator. I had made UiRobot as a windows service (under the context of an administrator account) and published a project also. It appeared on the list of “Available Processes” when i click on the UiRobot icon in Tray.
When i am clicking on “Execute” icon of my published project in the “Available Processes” list, an error “Permission missing : Launcher” is displayed.
Is there any other configuration/permission change that i need to do in order to run the process only with the robot i.e without orchestrator??.

Thanks.

1 Like

Hi Venkat,

Did you find a solution for this. I’m facing the same issue.

Regards,
Srinath

1 Like

This can also happen when there are multiple versions of UiPath installed on the same machine.

RD

1 Like

For myself (community edition) my community licence must have expired mid use (as in I was using uiPath fine, then the licence expired sometime while using it - and I received this error when i tried to run my project). It wasn’t until i restarted uiPath that I recieved an error about my licence had expired - at which point i reactivated my licence and then it worked fine.

1 Like

Hi there,

I get the same error (see attached) when trying to run an workflow from the Tray of a standalone Robot.
I’ve installed the Robot only from the .msi installer (trial license) and copied an working package from my dev machine - everything seems fine (package was successfully recognized and “updated”, but when i try to run it from the tray this error pops-up.
I’ve searched the forum and the documentation available on the site, but the whole “deployment scenarios” “thinggy” is still a bit foggy to me - can anyone point me in the right direction for further details?

Thanks in advance!
standaloneRobotError

LE: i’ve tried the install/uninstall/reinstall suggestions, checked the Windows services and everything looks OK (except the error, that is :slight_smile: )

Hi Adrian,

Did you license the Robot after installing?

Hi Ovi,

i just licensed it and it works.

Thanks a lot!!!

I’m glad it was just this. :slight_smile:

The error message will be changed in 2018.2 version to be more explicit on the licensing part.

hi,ovi
i have installed the studio from the .msi,the version was 2018.1.4.when i used “start free”,it work well,
but after i activated it use the license that my company bought,i activated successfully,when i runned a simple process,it happened the same issue,What’s the reason?

Did you check in Windows services that the Robot service is started?

the Robot service is started. i uninstalled the studio,and reinstalled,but it had no effect.