Error locating fields in Login - Robot loses focus as soon as it opens the "Open Browser"

I have robots that are in Production, created in the years 2020 and 2021. These robots need to log in to banking websites or client-owned websites as an initial step, and then go to the different screens and capture the data that the process needs. These bots mentioned, worked fine until the end of 2021 and then experienced intermittent errors on the login screen due to the bot losing focus of the webpage preventing the bot from typing credentials. These intermittent bugs were most apparent from earlier this year to date.
Weeks ago, I published a similar query (which I leave the link)

asking for your support to solve this problem, which is simply that the robot, sometimes, opens the web and when trying to fill in the login fields, the The first field is not found and therefore it fails due to a timeout error indicating the field could not be found. It was seen that the robot loses focus when opening the web, since when we help it, by clicking on the page, it continues correctly. This happens in all robots that have Login. The solution they gave me worked for 1 week, for which I thought it was the definitive solution, however, the error occurred again and currently all my robots have this intermittent error (sometimes it happens and sometimes it doesn’t).

I would like to know if, after the new versions of the uipath, there is a development standard for those websites that have a login. Since my problem is only there, when the robot manages to log in everything continues perfectly.

validations you perform:

  • no pop-up or pop-up when logging in, it just loses focus.
  • The robot has attach when opening the url with the open browser, however it still fails.
  • the web loads correctly and quickly, however the robot loses focus.
  • COMPLETE was selected in the Wait for ready property, however it still fails.
  • It was validated that the resolution with which the robot was created is the same as the target machine where they are executed in an attended and unattended manner, however it still loses focus.
  • My UiPath extension is configured as follows:
  • The version of the chrome that I use is the following: 98.0.4758.102 (64bits)

please your respective support

If there is any image in the login screen you can use retry scope to handle these kind of exceptions. just try out retry scope and see.

It may be a possible solution, however I still can’t understand why before if it worked for almost 1 year my robots that were in production and now present these errors. An additional point is Chrome, last year I had a version (apparently more compatible with UiPath) and now I have these errors with a more current version (does anyone know something if with the new version of chrome, which I detail lines above, I must previously do some extra configuration on the VM to make it work fine?). It is important to know that I did the same login again with the new version of Chrome, however it presents the same problem.
Do you know if there is a configuration at the level of a server, PC or virtual machine so that everything works correctly? The virtual machine that is the one I use is exclusive for robots.

How did you install the chrome extension? per policy?

it is correct Thanu, it is already installed

Another possible approach is you can now use UiPath modern design selectors to create more robust selectors. Try to enable UiPath modern design and use modern activities to identify the selectors.

@Jean_Piere_Ochoa one explanation could be the fact that Windows got updated and something similar to this might happen: "News And interests" Feed Is Enabled On Windows v1909, Causing UI Automation To Stop

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.