Error in RE Framework RPA Challange

I am trying to perform RPA Challange using RE Framework. I am using Assets and Queue instead of config sheet to fetch the values and perform the transactions.
I am getting this error “Type Into- First Name: The given key was not present in the dictionary.” while running the code. Please suggest the solution. I have attached the code for reference.

Thanks in advance :slight_smile:RPA Challange_REFramework.zip (1013.4 KB)

@Anamika15 Similar kind of problem was solved in an earlier post of yours. How is it different this time?

That time I did not use UiPath RE Framework…

@Anamika15 I think the problem is in the Add Queue Item Activity :sweat_smile: You are having “First_Name” (Double Quotes are present) as the argument name in it, but you are accessing the Queue Item in the Process as just First_Name (Double Quotes Not Present). The same name should be used to get the Data using the Queue Item Result retrieved from the Get Transaction Item. To make it simple you can just remove the “” in all the arguments in the Add Queue Item Activity.

1 Like

Thanks for the response… But modifying Queue collection as per your suggestion is not working. Getting the same error “Type Into- First Name: The given key was not present in the dictionary.” Please note that Multiple Assign activity in Get Transaction Data is disabled.
I guess there is some error in the Get Transaction Data and Process Data.

@Anamika15 Can you show us the Queue items in the Orchestrator Queue?

I have attached the Queue items for your reference:


@Anamika15 Do you have any other Queue Items with Keys as “First_Name” (With Double Quotes) in it ?

@Anamika15 This might be causing the problem, Can you Delete the Queue and Create it again so when you run the Workflow the Queue will have new items which will contain the keys without the Double Quotes. And then it should be possible to access the Values in the Process part.

Make Sure in Add Queue Item Activity the argument names do not have double Quotes

Thanks… That really helped :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.