Error getting transaction data for Transaction Number: 1. {"message":"KibanaDemoQueue does not exist.","errorCode":1002,"resourceIds":null} at Source: Get Transaction Item


#1

Dear Community,

I am stuck with UiDemo Walkthrough. Here is the screenshot of the trace . I don’t know how to get this removed and how should I see the output where the workflow worked correctly.

.

I am finding to difficult to grasp. Please explain and help me with this


#2

Delete the unnecessary names and values from config file.It is reading kibanademoqueue from your config file which does not exist in your orchestrator queue @Sachin_Hatikankan


#3

Thanks Sreekanth !
However, I was able to resolve the above issue by giving the appropriate ‘QueueName’ in GetTransactionData.
But now the issue is that process is getting finished as no transaction data is found. picture inline

I am sure that there are transaction data present in the “Transactions” excel. @sreekanth


#4

Go to orchestrator and open the queue and check the TransactionQueue and view transactions


#5

@Sreekanth Thanks! it worked.


#6

May I know why I am getting this.
I also changed the robot key , guessing that might be the issue. But I still got this trace.

@sreekanth


#7


@sreekanth
@Sachin_Hatikankan

Hi , I was following the question you had raised on UiDemo excercise.
I am having issue in the Performer ( Process Xaml ) .
I am unable to get read values from the queue populated onto to the UiDemo application.

When I execute my process the UiDemo opens but empty values are being typed into it.
So I suspect

  1. there are no values being passed from Robot to Studio.
  2. My invoke work flow


*---------------------------------------------------------------------------------------------------------------------

I suspect the way I have declared Cashin is wrong . I am reading a queue item to an object (Cashin) .Please can you help
image

*-----------------------------------------------------------------------------------------------------------------------

I looked at the output and I can see the the transaction number is being displayed . So I think the values are being read from queue. But It is not being typed into the respective fields.
image