Error detecting project version

for me, I just restarted the PC, and it worked.

1 Like

You saved my life

I got the same error message when I ran the robot on VM machine.
I used community edition studio which has version 2019.7.0 to develop the process.
We bought an unattended Robot license (version is 2019.4.4) and installed it on a VM machine without either orchestrator or studio installed.
We don’t want to install the community edition studio on production environment. How can we keep both studio and licensed Robot synchronized all the time? Is there a way I can open my project in version 2019.4.4 by using community edition studio?

Thank you very much for your help.

Thanks Lukas this one did the trick

@Lukas_Macas just want to check. Will this work for robot version 2019.4.4 with studio CE version 2019.7?

@seanrockvz13 It works with version 2019.4.3 for me.

Thanks Lukas! It’s really works!

muchas gracias, esta era la respuesta que estaba buscando, cambie la version y el robot se ejecuto sin problemas.

This works.

worked like a charm

Thank you indra…you solved my issue

1 Like

Did not work for me. Btw I have no Studio installed. Just the Robot…

Because when I do Publish, it always resets the Schemaversion back to 4.0.

Hi @kwoxer

Are you maybe executing project made on a newer version on a robot from an older version? This scenario is not officially supported (older robot will not be compatibile with newer features of the newer studio).

If not supported you should definetily say that on the install page. That does not make any sense. Why should someone create a process and later not being able to run it on robot on other machines. This is pretty much a showstopper to me. Now I have to install Studio on several machine just to make a workaround around that “bug” in the system. That’s not a nice thing and you should definetily fix that or at least communicate this in a better way.

A link to my latest concerning question: Getting "Error detecting project version" when project is run on machine with a minimal UiPath Robot installation

If you facing this issue most probably this is due to version mismatch. Create new project and copy it’s project.json dependencies. And now paste it into the same directory of error file. Now it must work. Notify me if it works

Hi,

I have developed a project using Studio CE versions 19.8. and 19.10.
Then I uninstalled Studio and replaced it with licensed Enterprise edition version 19.4.2.
Now I’m getting this error: “Error detecting project version”
Is there any solution for this problem, for example a compatible Enterprise version with the latest CE versions?
Below is the screenshot of my project.json file.

Many thanks in advance!

Hi @BhnAmn

This is normally not supported. You could try to fix by a modification to your project.json file like explain here:

Although this particular tutorial is for our Academic Studio Edition which might have a different version than the Enterprise one you have.

I also changed also “studioVersion”, because it didn’t match

@q.gio

Create a new Re-Framework project, copy that project.json file to your old Project folder and try

Thanks

Thank you.