Error connecting to uirobot service

I’ve previously connected the UiRobot to the Orchestrator, but when I restarted my computer today, and opened the programs, it was not syncing up. On my desktop, the UiPath logo was red. When I opened the setting, I was unable to paste the Robot Key and html address from orchestrator (I provided a picture of that below). I read a couple of other similar issues, but they were not exactly the same, because the bot worked for me before and now I cannot even update the fields to connect it.

status error connecting to uirobot service

Have you tried restarting the uiRobotSvc?
You can do that in Task Manager or Services.


1 Like

Hi Pedro,

If you are using Enterprise version, please restart the Robot service and try again.

If you are using Community Edition, close the tray(from Task Manager, End Task “UiPath Robot”) and reopen it from %localappdata%\UiPath\app-17.1.6522\UiRobot.exe


Thank you @ClaytonM and @ovi

I tried restarting the uirobot from Task Manager and on my start menu. However, when I reopen it using the uirobot.exe file, it’s still opening with the same problem. So it’s still causing producing the same error without allowing me to connect the robot to the orchestrator.

Also, I don’t see the uirobotsvc file. I am currently using UiPath community edition.


even i am using community edition and i am getting the same error

can someone help me on this?

Am also experiencing the same issue. I am using community version. Can anyone help on this?

am also blocked with the same issue. any updates ?

I too have now encountered the same issue. This is all recent with move to 2018.4. If I launch the Robot as version 2018.2.3, then it appears to work and connects to Orchestrator, but cannot run anything in Studio 2018.4, so I stop the Robot and relaunch it with version 2018.4 and like above, it is red and the Orchestrator Settings fields are disabled. Thoughts? suggestions ?

Hi @rstaylor62

Please check the path to the UiPath service in your Task Manager. It should point to the folder with the version 2018.4. If the service that is running does not much the running version of the software it will not allow you to connect to Orchestrator. The easiest fix is to make sure you only have 1 version installed and to always restart your machine after the installation (to allow for the service to restart).

It is important to reiterate that two versions of the software installed at the same time are not supported.

I am using 2018.4, community edition and the same problem. unable to connect the robot, and uirobot doesnt appear eitheir in services… help

same here.

This could mean that there might be something stopping the service from being active/installed. Could you try reinstall the Studio?

Just for clarity, Robot service looks like that: