Error BC30652 System.Runtime.InteropServices after Update yesterday

Thanks for your reply.
I deleted the GetUsername/Password activity as well as the variable containing username and password. I also deleted the SAP Login activity and saved everything.
After readding all activities the error is still the same.


Can you please try upgrading your packages to latest version

Alternately close the project and rename the project.json file and reopen the project


I updated all packages and tried to rename the project.json and reopen the project.
The error persists :frowning:


Is it possible to share the project here?

If not as one more resort…try renaming the packages folder inside .nuget foldwr and then reopen the project.This is to make sure the packages are downloded again freshly


Can you share some screnshots if not the project


No success with renaming the packages-Folder.
I cannot share the project itself but I will try to provide the screenshots (one by one due to forum restrictions:


Get Username/Password and put it into “SAP_BQ1” Variable:

SAP Logon and Login with SecurePassword as part of the variable above:

Specs of SAP Login:

Error message:

Any ideas what the problem might be?
Maybe it’s a bug in the recent release of StudioX?
The problem even persists after rebuilding the process from scratch.


Did you do the .nuget steps as well?

That will ensure new packages are downloaded properly again


Yes, I did the .nuget steps as well.
As far as I could see, all packages where downloaded again.


After the new download …did you try replacinf the effected activity


I did not only replace the affected activity, but also created a whole new project rebuilding the login.
In both cases the error persists.


Try changing the versions of your packages from the preview versions to anything lower…which refers to different version of interop…probably 4.x


I tried to install packages 22.4.X without success.
The error message is still the same but saying:

Main.xaml: (2) : error BC30652: Es ist ein Verweis auf die Assembly “System.Runtime.InteropServices, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a” erforderlich, die den Typ “SecureString” enthält. Fügen Sie dem Projekt einen Verweis hinzu.

So the Interop version in the message is now instead of in the initial message.


Try downgrading more…as of now i guess it working with introp 4.3 version or lower…starting ll its trying for 5.0



I can not downgrade UiPath.System and UiPath.UIAutomation activities below 22.4.X.
In versions 21.10.X another error raises saying the main.xaml is broken.


As workaround, can you try to modify your xaml file with notepad as the following step? Similar problem (secure string and System.Runtime.InteropServices) have been solved by this.

  1. Close Studio
  2. Copy your xaml file(Main.xaml?) to other place for backup
  3. Open your xaml using Notepad (or any text editor)
  4. Add the following element inside <sco:Collection x:TypeArguments="AssemblyReference">
    (There are many AssemblyReference elements)


  1. Save it
  2. Launch Studio, then open the project.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.