Error BC30456 "Cast is not a member of "GroupCollection"

Hello all

I just wanted to publish my automation in Studio but I receive the following error message:

Does someone know what the error message means? I have no idea what I need to change in the expression editor in order to remove the error message. Thank you in advance for your help!

Hi @morseil ,

Could you let us know what is the currentItem data type ?

Yes. It means that the Groups property on your currentItem doesn’t contain a method called ‘Cast’.
Where did you get that code from? Thats not how you cast a datatype in VB.Net

Hi @supermanPunch

You helped me then with the solution how to read the PDF.

It always worked and now I get the error message.
It looks like this:

@morseil ,

Could you maybe try to remove the whole value and add it again and Check. Do it in the following way :

  1. Remove the value.
  2. Click on Ok and save the empty value.
  3. Add the value again.

Also try Closing and Re-Opening the Studio. It does seem to be a Bug.

I removed the value, saved it and closed the Studio…
Unfortunately, the error message still appears… :confused:

@morseil ,

Could you let us know what are the Dependencies along with their versions used in the project ?

Please share a sample project so we can replicate the issue on our side.

@alexandru @supermanPunch

The process looks like this:

I created the automation with the following code:

Is it legacy or windows project. What is the type for current item in for each activity?

@morseil ,

A Similar kind of an Error message was solved when updating the dependencies to the latest Stable version. Check the below post :

If the issue till persists, then could you provide the project as a zipped file as already mentioned above. We can replicate the issue from our end and maybe get to know the cause.

Also note that, you have not shared the Dependency packages and their versions being used.


These are the Dependencies.
If i run the automation, it works smoothly.
The error message just appears, when I want to pubilsh the package.

@morseil ,

As mentioned already, could you try updating/Downgrading to the latest Stable versions.
Make sure there are no preview or beta versions.

It seemed to have solved the issue. We can check if it is the same for your case as well.


The error message still appears… if i rebuild this small automation part in a new project, the error does not appear (with the same dependencies) however, strange.

@morseil ,

It maybe because there were incompatibilities between this individual workflow when integrated with the whole project.

If this workflow is an individual workflow or separate from other workflows. Do Check by Deleting the workflow and check if you are able to publish the remaining.

Then try to add back the workflow that you have built separately to this and check again.

Also, As mentioned in the post, if you provide the project as a zipped file where this issue occurs, the UiPath Team could investigate on this and provide a possible fix. It would also help understand and fix the future issues that may arise.


i first deleted the content only here, saved it and then redid it again.

Now I have deleted the content on the page in the Properties section, saved it and then i added it again. And now it suddenly works again… Ouff thanks a lot!


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.