Error 'An error has occurred.' in list of Packages

packages

#1

I have a new installation of Orchestrator.
My Robot is connected and the robot on my local mashine (with Studio) is also connected.
In Orchestrator I have created two envcironments with each a robot (production and test). No problem with that.
When I publish a project from local, everything seems ok. In the receipt I can see the URL of the Orchestrator server:


Info

Project published successfully to
https://orchestrator.ballerup.dk/

Package Name: Statistik
Package Version: 1.0.6612.23981

Press Ctrl +C to copy the information.

OK

Now when I Select PROCESSES and click Packages-tab, I get the error ‘An error has occurred.’

I also tried to manually upload the package, and that gives the exact same error message.

Any ideas what is wrong?


#2

Hi @lodahl,

My first thought would be that something is wrong with the Deployment URL. In Orchestrator Settings - Deployment, what is your deployment URL and API key?


#3

Hi @ovi,
Thanks. Here are the details from Deployment. I have X’ed out some chars for security reasons.
Depolyment URL=https://orchestrator.ballerup.dk/
API key=DE9BE119-DAD0-XXXX-A95A-6A8650086XXX

Note that both from Orchestrator and the robots, connection seems to be fine.

Could it be configuration? Are Orchestrator trying to put the packages somewhere without having write access?


#4

I found out that my Robot-role doesn’t have access to Create or Edit Packages.
Theoretically when publishing a package from Studio to Orchestra, this is done through the Robot, isn’t it?
Sorry, I’m newbee here :slight_smile:

Cheers,
Leif Lodahl


#5

No, the Robot role is by default and it has nothing to do with Packages.

In Deployment URL field you have put the Orchestrator URL, not a repository. You either put a myget feed of your own(In Orchestrator CE it is https://www.myget.org/f/orchestrator - just an example) or you leave those fields empty and the repository will be a local one that it will automatically get retrieved from web.config(it’s there by default when you first install the Orchestrator).

So if you leave the Deployment URL and API key fields empty and you publish from Studio, your packages will appear in Orchestrator - Packages page(if your Robot is connected to Orchestrator)

Try this and let me know if you still get the error.

Thanks!


#6

@ovi
Thank you very much. It helped, but not quite enough.

I cleared both Deployment items.
Now there is no more error in the web interface (good).
But I still don’t see any packages even after re-publishing from Studio.
If I upload manually I can see it.

So bottom line it looks as Orchestrator is working (thanks for that) but Studio can’t publish to Orchestrator.

Studio is not publishing to it self, as I can’t see any of the lately published packages locally.


#7

@ovi
After I tried to disconnect and reconnect the local robot, I can publish from Studio to Orchestrator.

So …

Case closed and thank you very much for your help.

Cheers,
Leif


#8

That’s great! Phew! :smiley:


#9

Hi,

I am getting the same error now every time i try using the Orchestrator.

I am stuck on this and cant use the Orchestrator CE at all.

Request you to help me on this.

Regards,
Rajiv