Error Adding to Queue

Hi,

Can you help me to resolve the issue I am getting when I am adding the data read from excel to the queue?



Hi @Krishna_Murthy,

It looks like your references to the column values when you are adding the Queue items do not match the column names from the excel, can you try it again but with the exact column names when referencing the data in each row? e.g. row("[Exact column Name as it appears in Excel]")

let me know how you get on.

Many thanks,

Hi @Krishna_Murthy

In your DT your passing a null value. Check the PropRef column values.

Regards
Gokul

Hi @Djh,

Thanks for your swift response. After editing the suggestions, I still have the same error.


Hi @Krishna_Murthy ,

in the provided excel where are these SCyearenddate and startdate columns. Can you please show them as well.

Thanks

Hi @Shikhar_Tandon,

Sorry to make you confused. I am not using a read range before adding to the queue. Once the data is read from excel, I am modifying the datatable and then pushing it to queue.


Output DataTable

Hi there @Krishna_Murthy,
I hope you are having a fantastic Wednesday.

Looking at the output provided, it appears your value for scYearStartDate is blank.
This is likely what is causing the problem when attempting to convert it.

Please let me know your thoughts.

Thanks once again for your support,
Josh

Hi @Krishna_Murthy ,

as suggested by @Mr_JDavey , scYearStartDate is appearing to be blank creating the issue.

you can create a control check before adding the items to queue. If this field is blank as per control built then you can pass either a " " space in it or any other thing as per your business req.

Thanks

1 Like

Hi all,

InstructionStartDate and Instruction Enddate is the one causing the error. Once I removed these two from my build data table, it worked perfectly fine. My issue is resolved now.

This is how my data looks now:
image

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.