Error 80040154 when running the recording

Hello everyone,

I have an error 80040154 when I run a simple recording to click on Windows “Start” button. This problem is the same for all recording types that I have tried.

Could someone help me, please?

Thanks in advance

Fabricio Tiburcio

Follow a stack trace for example:


Source: Send Hotkey ‘easytec.exe Easy’

Message: One or more errors occurred.

Exception Type: System.AggregateException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.AggregateException: One or more errors occurred. ----> System.Runtime.InteropServices.COMException: Falha na recuperação de fábrica de classes COM do componente com CLSID {F497F7BF-B0C1-415B-8AFE-31484878AE5F} devido ao seguinte erro: 80040154 Classe não registrada (Exceção de HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
at UiPath.UiFactory.NewUiNode()
at UiPath.Core.UiElement…ctor(SelectorStrategy strategy)
at UiPath.Core.Activities.Target.<>c__DisplayClass29_0.b__0()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
— End of inner ExceptionDetail stack trace —
at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
at UiPath.Core.Activities.Target.GetBaseElement(ActivityContext context, CancellationToken token)
at UiPath.Core.Activities.Target.GetElementAsync(ActivityContext context, CancellationToken cancellationToken, Nullable1 delayBefore) at UiPath.Core.Activities.SendHotkey.ExecuteAsync(AsyncCodeActivityContext context, CancellationToken cancellationToken) at UiPath.Core.Activities.TaskAsyncCodeActivity.ExecuteAsyncWithResult(AsyncCodeActivityContext context, CancellationToken cancellationToken) at UiPath.Core.Activities.TaskAsyncCodeActivity1.BeginExecute(AsyncCodeActivityContext context, AsyncCallback callback, Object state)
at System.Activities.AsyncCodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Have you written something inside the workflow or you just started with recording inside the workflow.

I have just started to record my action without other components inside the workflow.
The “strange thing” is that “Recording” works fine in another machine. Logical conclusion, is something at this machine, but what? All Windows updates are ok, it is hardware and software compatible with uiPath.

Any idea?


Hi @Fabricio_Tiburcio

You might need to reinstall the Studio on your machine. It helped someone in the past with identical error code:

I have tried to reinstall Studio but the same problem happened. It only happens with UI Automation activities (click, keyboard, etc). I have tried to uninstall and install only this specific package of UI Automation too.