Error 40 , database connection not working

Hi ,

I am getting below error while trying to connect to the application database. Need suggestions

image

2 Likes

@RobDev,

May I know from where you are trying to connect, and also check the below steps.

Step 1) Make sure SQL SERVER is up and the instance you try to connect is running.
Step 2) Your system Firewall should not block SQL Server port.
Step 3) Go to Computer Management >> Service and Application >> SQL Server 2005 Configuration >> Network Configuration
Enable TCP/IP protocol. Make sure that SQL SERVER port is by Default 1433.

1 Like

Hi ,try use 32 bit oracle client to connect to DB

1 Like

I have checked the connection in Sql developer and itโ€™s working. I donโ€™t have sql server 2005 available in the mentioned path, is it something I need to install ?

1 Like

Can you please provide details of how can I do this ?

1 Like

Hello,

Maybe this is an old post but the below information can help the members in the future.

This error appears mostly when:

  • SQL Server does not allow remote connections
  • Firewall Settings
  • TCP/IP is not enabled.

Fast checks to fix this error:

  1. Check SQL Server is running
  2. Make sure that Allow Remote Connections is enabled on sql server properties
  3. Check if TCP/IP is enabled
  4. Configure to allow SQL Server in Firewall Settings
  5. Check for working fine SQL Server Browser
  6. Make sure that you can ping the SQL Server

You can check step by step the above fixes at https://www.get-itsolutions.com/sql-server-error-26-sql-error-40-fix/

Thnx

you must setting ODBC , https://www.youtube.com/watch?v=o_xusIY3BH0
maybe see some URL
have fun