Entry point must be a file inside the current project - Error Message (Assistant Only)

When ever I try to run a bot through the Assistant and bot contains an invoke workflow activity. I get the following error:

Entry point must be a file inside the current project. The used file was:

at UiPath.Executor.WorkflowLoader.LoadWorkflow(String workflowFile)
at UiPath.Executor.InProcessRunner.BeginExecute(AsyncCallback callback, Object state)
at UiPath.Core.Activities.ExecutorInvokeActivity.BeginExecute(AsyncCodeActivityContext context, AsyncCallback callback, Object state)
at System.Activities.AsyncCodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

This seems specific to when I’m invoking a workflow from “another project” and only occurs in assistant. Whenever I run the bot in Studio it works perfectly.

Any Ideas what this could be? I’ve looked around the forum and I similar issues but not specifically this one, and have not been able to find a working solution.

Thanks!

1 Like

I am getting a very similar error:
System exception at initialization: Entry point must be a file inside the current project. The used file was: Main.xaml at Source: UiPath.Executor.Core
This happens when running an unattended robot from Cloud Orchestrator. The robot also has several invokes.
It started today after I updated studio on my unattended machine.

Sorry I cant help with a solution, but might add to the problem…

I agree that this does appear to be centered around the latest update. My issues started around the same time.

I’ve already:

  • Removed uipath and reinstalled.
  • Manually removed all of the installed packages and let assistance reinstall them.
  • Tried to republish projects with the latest update.

All with no success!

Same thing is happening to me since I updated UiPath version! I execute it from Orchestrator and the error appears, but it works fine when executing the process from Studio. Also, it’s only happening for one process, even though all my processes invoke workflows.

It seems to only happen if the workflow being invoked is placed outside of the running project.

This is not my case. Any other sugestion?