Entry point failing

Hi all,

I am doing a test of “Hello World” using Invoke workflow and arguments.

I have a main.xaml that first gets from a invoke workflow a variable that contains “Hello World!”. In this workflow I have created an out argument called Text.

Then in the main.xaml I create an in/out argument called Text and use a message box activity with argument Text and it works. After that I have used an assign activity to change the argument Text = “Hello World!” to Text = “Another World!”.

Then I am using an invoke workflow that contains a message box with an in argument called Text

This is working using Studio, but using orchestrator it appears the following error:

Entry point must be file inside the current project.

I am using as entry point main.xaml.

The other sequences are in the same folder as main.xaml

Do you know why is this happening?

Many thanks!!

@Angel_Llull

Check below thread for your reference

Hope this will help you

Thanks

@Angel_Llull

Right click on the Main and check if you are getting the below options to set as Main

Hope this will help you

Thanks

Hello @Srini84,

Thanks for your reply!

I have the Main.xaml as main:

image

Which workflow should I have as main?

Hi @Angel_Llull

I Guess you re displaying a Hello World using Message box !

Set Message Box.xaml as main run the process!

Regards

Hi @Angel_Llull

If you re invoking the Process Message box.Xaml in Main.Xaml You need to create a arguments in Message Box .xaml and In Main.xaml need to invoke the message box.xaml and the variables to the arguments !

Regards

Hi @Angel_Llull

You must have to set the entry point which xaml is going to be triggered if you have use the invoke workflow file to run the message box.xaml from the main.xaml then you need to set the entry point as main

Check with the reference zip file below!

sample.zip (3.4 KB)

Regards

Hello @pravin_calvin,

Firstly, many thanks for your support :slight_smile:

I have checked the file you sent me and it contains one invoke workflow. In my case I have to invoke workflows. The first one is doing the same as you sent me. It is passing the Message to the main.xaml. Then, I want to send this message to a second workflow: from main.xaml to mensaje.xaml. Here is when the error comes.

If I establish as entry point Messagebox.xaml it is not running. If I establish as entry point Mensaje.xaml the message is empty because it just executes this sequence and the message is empty. And if I establish as entry point Main.xaml it gives the error I commented.

I attach the project.
SampleMessage.zip (38.9 KB)

Hi @Angel_Llull

I have slightly modified your workflow as your getting the value from the one workflow as out argument and passing as input to another workflow by altering the to another string!

Check with the reference zip file below and publish it and set entry point as main it will run and make sure that invoking xaml are in correct path!

testFile.zip (4.7 KB)

Regards

1 Like

Hi @Angel_Llull

Does the above method satisfy your needs?

Regards