Enterprise Studio : Cannot open project. Could not find “.DLL” file from C:\programfile(x86)

Hi Team

Problem statement : pls refer attachment

Background:

1.Migrating from Trial Standalone studio 2018.4 to Enterprise 2019.10
2.Due to company policy, cannot use standard installation path “C:\Program Files (x86)…”. hence using custom installation path. it is mentioned in Setting>Manage Source>Local. Also created default package source again after failure with installation path.

While opening new/existing project, it still refers standard installation path and throws above error message …

FYI - licensed Studio properly from orch… Old license are uninstalled and deleted %appdata%. properly.

May i ask,Can use custom installation path ? if so, whats the right way ?

If it’s about a particualr project.
The reason could be, your project is referring to files in default setup up.
Open your project json fine and see if there is any dependency.

@Lakshay_Verma

Not specific to one project … old or new project … … missing is product’s inherent “.dll” file. it is available in location path mentioned in default package source and selected. but not picking from there

@RPA-Fresher

Well if that’s the case, Reinstall using below link.

1 Like

@RPA-Fresher

UiPath has a default location and this error is because of studio is looking some dll’s from the default location, You can try by placing the error dll is the default location and try

If still it didn’t resolves, you better to reach technical support of UiPath, they can serve you better

Hope this helps

Thanks

1 Like

@Lakshay_Verma
thanks. We followed the link as basic prerequisites. For custom installation path via “APPLICATIONFOLDER”, which is mentioned rightly in setting <Local. Whats the specific suggestion to follow?

@ksrinu070184
thanks. Pre-req installation document says it accepts to do customer folder reference for installation path. anything else, am i missing ?

Well, Preferably…
Only thing that needs to be followed is this.

Click Here

Based on your problem statement :-

  1. APPLICATIONFOLDER
  2. PACKAGES_FOLDER

Silently install Studio, the Robot as a Windows service and the activities packages, all in the

D:\UiPath folder - UiPathStudio.msi ADDLOCAL=DesktopFeature,Studio,Robot,RegisterService,Packages APPLICATIONFOLDER=D:\UiPath /Q

Silently install Studio, the Robot as a Windows service, and add two custom activity feeds -

UiPathStudio.msi ADDLOCAL=DesktopFeature,Studio,Robot,RegisterService CUSTOM_NUGET_FEEDS="Feed Name1, https://my.custom.nuget.feed; FeedName2, D:\RPA\Activities\Packages\" /Q

1 Like

@Lakshay_Verma
thanks for highlighting. we followed this step too as part of installation.

Well, If it still didn’t work, rasie a ticket with support team. This is a rare scenario and RCA is needed for such cases.

1 Like

thanks @Lakshay_Verma. could be some issue in my installation sequence.
Previous trial version was using default installation location C:\Program Files (x86)\UiPath\Studio.
Due to Prod policy, it got to be custom loc.

Appreciate your time and effort. nice.

1 Like

@RPA-Fresher

Thanks.

Happy Automation :slight_smile: