Enterprise license published robot not updating to the latest version

There are 2 PC here. Both enterprise Licensed.
PC A can edit and publish robot
PC B can only display and debug robot from PC A
Here is the question.
Basically I copy the package from A to B
At first, the robot version on B is v23
After I copy version 24 to B, the version should update to v24, but it’s not updating.
Even if I overwrite v23 on B, it still not updating to v23, it shows v22.
How can I transfer v24 from A to B?


pc2

any reply?

any update?

Hi @CharlotteG ,

The easiest way to deploy process from one PC to another is to use Orchetrator.
However, it seems that your robots (PC A and PC B) are not connected to Orchetrator and you are publishing locally the processes.

A workaround for your issue is to open and publish the .xaml file with PC B

And, perhaps it sounds silly, but did you refresh the list from UiPAth Assistant?
image

Best regards,
Marius

Thank you for replying.
Both enterprise licensed PC do not need to connect to Orchetrator.
And also PC B cannot publish any.xmal file since the publish button is grey.
PC B can only display and debug.
The refresh button was clicked but it still not showing the latest version.

Hi @CharlotteG ,

It seems that you are using an old version of the UiPath Assistant.
Please check the files from %userprofile%\.nuget\packages folder.

Source: Introduction

Best regards,
Marius

1 Like

Thank you for your solution.
Problem solved!
Really appreciate your help.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.