Entering password into Gmail's password is not working. It clicks on Next button before entering password

Hi, Entering password into Gmail’s password is not working. It clicks on Next button before entering password. It always fails here. i tried to give “Delay Before” and “Delay After” for Input field and also for Clicking next button, still not resolvd. Please help.

image

BTW, I am trying to automate plugin installation on gmail for which I need to login.

Hello there,
Could you post a picture of your workflow?

Hi @Enache_Andrei, here is the screenshot:

Hello there,

I’ve tried to recreate what you just did here and I faced the same situation. The problem is the loading time. I was able to solve it using the delay.
Could you let me know what delay value did you use?
You can also try to increase that delay before the password input.

A second option is to try and play a bit with the type into property called “wait for ready” as in the picture below:

If that doesn’t work, what I would try is to make sure that the page is loaded properly using an “Element exist”.
It should look like this:

Element exist outputs a boolean value which you can assign to a variable like in the picture below:

Note:
The input field of username/email and the input field of password have different selectors used so what are we trying to do with that “element exist” is to make sure that the password page is loaded properly and we are able to tell that if the password input field is loaded. You can see how the selectors are different in the next pictures:

I might be right, I might be wrong,
Hope that helps,
Cheers!

1 Like

Thank you @Enache_Andrei. I increased the delay_before to 8000 and Empty_field=true, which resolved the issue temporarily. But will definitely consider While loop logic, if this also does not work and as a permanent fix.
Thanks again.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.