End of Expression expected error message displayed while publishing

Hello,

I am a newbie and 2 days back started studying UiPath. While publishing my first program I am getting “End of Expression expected” error message. I have tried to solve it but unable to do so. kindly request you all to help me and solve this problem. In advance many thanks

Attaching some relevant information such as log and error pop up message.

Logs:-

18:42:34.5180 => [INFO] [UiPath.Studio.exe] [1] The settings file ‘C:\Users\BHADRESH\AppData\Local\UiPath\UiStudio.v2.settings’ could not be found.
18:42:35.4260 => [INFO] [UiPath.Studio.exe] [1] ApplyReleasesImpl: About to create shortcuts for UiPath.Studio.exe, rootAppDir C:\Users\BHADRESH\AppData\Local\UiPath
18:42:36.0376 => [INFO] [UiPath.Studio.exe] [1] ApplyReleasesImpl: Creating shortcut for UiPath.Studio.exe => C:\Users\BHADRESH\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\UiPath\UiPath.lnk
18:42:36.0376 => [INFO] [UiPath.Studio.exe] [1] ApplyReleasesImpl: appUserModelId: com.squirrel.UiPath.UiPath.Studio | toastActivatorCLSID: cd4206b4-70f2-5276-9502-13a0edb689a9
18:42:36.6281 => [INFO] [UiPath.Studio.exe] [1] ApplyReleasesImpl: About to create shortcuts for UiPath.Agent.exe, rootAppDir C:\Users\BHADRESH\AppData\Local\UiPath
18:42:36.6751 => [INFO] [UiPath.Studio.exe] [1] ApplyReleasesImpl: Creating shortcut for UiPath.Agent.exe => C:\Users\BHADRESH\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\UiPath\UiPath.lnk
18:42:36.6751 => [INFO] [UiPath.Studio.exe] [1] ApplyReleasesImpl: appUserModelId: com.squirrel.UiPath.UiPath.Agent | toastActivatorCLSID: 97f22354-1eb3-511e-9c99-01631708a885
18:42:39.7998 => [INFO] [UiPath.Studio.exe] [1] Set native thread language to LangId=0x0009
18:42:46.3328 => [INFO] [UiPath.Studio.Shared.MVVM.Commands.CommandManager] [1] Application.MainWindow is null, cannot subscribe to keyboard events, subscribed to Application.Activated event
18:43:04.7660 => [INFO] [UiPath.Studio.exe] [5] BusyWaitForRobotConnectionStatus took 5868 ms.
18:43:32.1899 => [INFO] [UiPath.Studio.exe] [1] IUpdateManager: Starting automatic update
18:43:32.3519 => [INFO] [UiPath.Studio.exe] [1] CheckForUpdateImpl: Generated new staging user ID: d1f54b70-7ee2-5efb-b5ae-748743e79d2b
18:43:32.4020 => [INFO] [UiPath.Studio.exe] [1] CheckForUpdateImpl: Downloading RELEASES file from https://download.uipath.com/latest?timestamp=636899138121658940
18:43:32.6797 => [INFO] [UiPath.Studio.exe] [1] FileDownloader: Downloading url: https://download.uipath.com/latest/RELEASES?timestamp=636899138121658940&id=UiPath&localVersion=19.3.0&arch=amd64
18:45:00.8642 => [INFO] [UiPath.Studio.exe] [8] Installing packages: UiPath.UIAutomation.Activities, UiPath.System.Activities, UiPath.Excel.Activities, UiPath.Mail.Activities
18:45:01.4431 => [INFO] [UiPath.Studio.Shared.Logging.OutputLogger] [8] Restoring packages for FirstRobotHello…

image

Hi @BhadreshPatel,

Can you delete the above 2 files where you have validation errors or resolve them and then publish your workflow.

Open your xaml files that have errors and click Validate, the one you see below.
image

This will take you to the activity that has validation errors. You can mouse hover the warning symbol to display the error. You can resolve the errors accordingly or delete the activities if you had included them for trial or by mistake.

image

Welcome to the forum! :slight_smile:

1 Like

Thank you guys for your valuable solutions.

The issue has been resolved now. :slight_smile:

1 Like

One quick suggestion. As you are new here…
Pls choose the post that solved that solved your problem so that other newbies can get benefited.

image

1 Like

Hi
This the text i passed in Type Into. I am getting an error End of expression expected. Can anyone help please.

“((‘Active Org’ = “IT-ENTRPRS-SDEL” OR ‘Active Org’ = “IT-ENTRPRS-ALL” OR ‘Active Org’ = “IT-ENTRPRS-APPS” OR ‘Active Org’ = “ServicDesk-All” ) AND ( ‘Work Queue’ = “ASOC” OR ‘Work Queue’ = “BRASS” OR ‘Work Queue’ =“BBW_PSO” OR ‘Work Queue’ =“OT-USM-SDEL” OR ‘Work Queue’ =“CSNP/DSNP SUPPORT” OR ‘Work Queue’ =“MBOS SUPPORT” OR ‘Work Queue’ =“SPS-DV”) AND ( ‘State’ = 0 OR ‘State’ = 1 OR ‘State’ = 2)) OR ((‘Active Org’ = “IT-ENTRPRS-SDEL”) AND (‘Work Queue’ = “NC3-SDEL”) AND ((‘Location ID’ = “US”) OR (‘Location ID’ = “UNKNOWN”)) AND ( ‘State’ = 0 OR ‘State’ = 1 OR ‘State’ = 2 )) OR ((‘Active Org’ = “IT-ENTRPRS-SDEL”) AND (‘Work Queue’ = “NC3-SDEL”) AND ((‘Location ID’ = “EMEA”) OR (‘Location ID’ = “AP”) OR (‘Location ID’ = “Canada”) OR (‘Location ID’ = “CA/LA”)) AND ((‘rept svc line desc tx’ = “NODAL”) OR (‘rept svc line desc tx’ = “MIS”) OR (‘rept svc line desc tx’ = “FLEX”) OR (‘rept svc line desc tx’ = “BVOIP”) OR ((‘rept svc line desc tx’ = “HSIA”) AND (‘rept svc line desc tx’ = “BVOIP”)) OR (‘rept svc line desc tx’ = “Private Line”) OR (‘rept svc line desc tx’ = “IPS”) OR (‘rept svc line desc tx’ = “SBS BUNDLE”) OR (‘rept svc line desc tx’ = “Voice”)) AND ( ‘State’ = 0 OR ‘State’ = 1 OR ‘State’ = 2 ))”

Double quotes will mark the end of a string value @rahakram
In case your text to enter has double quotes, replace them with two double quotes. Like this, for example - "(('Active Org' = ""IT-ENTRPRS-SDEL"" OR 'Active Org' = ""IT-ENTRPRS-ALL""))"

This should solve your problem