"Empty Field" in "Type Into activity" only clears the last line of the editable section


#1

Hi Seniors

When the notepad is not maximized, the extra words had to the next line due to a word wrap.

Using “Empty Field” in “Type Into activity” only clears the last line of the editable section. In this scenario only clears the last line. It doesnt clear the whole notepad. Is this a normal behavior or Am I missing something? Below are the before and after screen shots. Please have a look and advice

Before

After

Regards
Karthik


#2

Hello @Karthik_Govind,

Put your cursor at beginning I mean at first line.

Cheers,
Pankaj


#3

Hi Pankaj

Thanks for your response and time.
Tried, now it just deletes the first line. What remained in the second line remains there.

Regards
Karthik


#4

@Karthik_Govind uncheck simulate type


#5

yep done! I had checked in the forum and have cross checked if thats on/off. how do I share my .xaml here?


#6

Give some delay and check


#7

image

sure will try the delay part


#8

was it delaybetweenkeys? if yes, I have included 100 and still the same…


#9

Use delay activity and give delay in this format 00:00:03


#10

[quote=“indra, post:9, topic:54349”]
00:00:03
[/quote] Im not sure, I have included the delay activity in the prescribed format also tried with before and after delay in the type into activity… its the same still… while the notepad is maximized and everything is in 1 line, it clears it… but when notepad is resized(made small) it only clears the line where the cursor is

image

Regards
Karthik


#11

Hi @Karthik_Govind

What a weird behaviour, works same for me. Empty Field should absolutely clear entire text field of the notepad.

It does what it is supposed to when you turn off the option to wrap the lines. But cannot handle the wrapped lines for some reason.

One way to work around this issue would be to send a hotkey combination CTRL + A. But other than that, I think there is something wrong with the activity.


#12

Glad to know that its not just me! Thank you!
Did you try with the hotkey ctrl+A? I tried but the same result.

Regards
Karthik


#13

Indeed! I guess this is the way to solve this particular issue:


#14

Yep! Achieved through the workaround! Thank you!

Is there a way we can report this bug to Uipath?

Regards
Karthik