Elasticsearch and Kibana - Unable to see Orachestrator Indices

I was able to successful install Orchestrator, Elasticsearch and Kibana, Filebeat on our Windows Server and configure accordingly. What I am doing wrong !!?

Web.Config
target name=“robotElasticBuffer” xsi:type=“BufferingWrapper” flushTimeout=“5000”
target xsi:type=“ElasticSearch” name=“robotElastic” uri=“http://localhost:9200” requireAuth=“false” username="" password="" index="{event-properties:item=indexName}-{date:format=yyyy.MM}" documentType=“logEvent” includeAllProperties=“true” layout="${message}" excludedProperties=“agentSessionId,tenantId,organizationUnitId,indexName” />
/target

<rules>
  <logger name="BusinessException.*" minlevel="Info" writeTo="businessExceptionEventLog" final="true" />
  <logger name="Robot.*" final="true" writeTo="database,robotElasticBuffer" />
  <logger name="Quartz.*" minlevel="Info" writeTo="eventLogQuartz" final="true" />
  <logger name="*" minlevel="Info" writeTo="eventLog" />
</rules>

—Filebeat Configuration
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
Array of hosts to connect to.
hosts: [“localhost:9200”]

Enabled ilm (beta) to use index lifecycle management instead daily indices.
#ilm.enabled: false

Optional protocol and basic auth credentials.
protocol: “http”
username: “elastic”
password: “Password1”

elastricsearch.yml

  • module: elasticsearch Server log
    server:
    enabled: true

Set custom paths for the log files. If left empty,
Filebeat will choose the paths depending on your OS.
#var.paths:

gc:
enabled: true
Set custom paths for the log files. If left empty,
Filebeat will choose the paths depending on your OS.
#var.paths:

audit:
enabled: true
# Set custom paths for the log files. If left empty,
# Filebeat will choose the paths depending on your OS.
#var.paths:

slowlog:
enabled: true
# Set custom paths for the log files. If left empty,
# Filebeat will choose the paths depending on your OS.
#var.paths:

deprecation:
enabled: true
Set custom paths for the log files. If left empty,
Filebeat will choose the paths depending on your OS.
#var.paths:


Kibana.yml

The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: [“http://127.0.0.1:9200”]
#When this setting’s value is true Kibana uses the hostname specified in the server.host

setting. When the value of this setting is false, Kibana uses the hostname of the host

that connects to this Kibana instance.

elasticsearch.preserveHost: true

I see only following indices
kibana_sample_data_ecommerce
filebeat-6.6.0-2019.02.12
metricbeat-6.6.0-2019.02.12

Following are system incides
.monitoring-beats-6-2019.02.12
.monitoring-es-6-2019.02.11
.monitoring-kibana-6-2019.02.11
.monitoring-kibana-6-2019.02.12
.kibana_1
.monitoring-es-6-2019.02.12

GET /_cat/health?v
green open .monitoring-es-6-2019.02.11 YLsOWR_YSH6kMqoxSD4lkA 1 0 26470 12 10.6mb 10.6mb
green open .monitoring-kibana-6-2019.02.11 H5seQyK7QwGWRIB3-Lxovw 1 0 3336 0 970.8kb 970.8kb
green open kibana_sample_data_ecommerce S8pxRTBdQ-GE_D9Z28UirA 1 0 4675 0 5mb 5mb
green open .kibana_1 gGSr__2nTUOZmocErZfJ4w 1 0 356 24 1.4mb 1.4mb
yellow open metricbeat-6.6.0-2019.02.12 1N2Veg4xQjCi5vVYRbZwvg 1 1 12244 0 3mb 3mb
green open .monitoring-es-6-2019.02.12 KTjOfzu8RS2CP-GJ2JavFw 1 0 43607 72 17.9mb 17.9mb
yellow open rparcm jq8-dzYDTRCuv24HJ4JeVQ 5 1 0 0 1.2kb 1.2kb
green open .monitoring-kibana-6-2019.02.12 0Mib8E_OSmKFlFUPQ-CmIw 1 0 3955 0 1.2mb 1.2mb

3 Likes

Look for any extra spaces in the Logger names or other parameters. Our implementation has similar kind of issue.