Edge Extension not working - Could not communicate

Hi @Daniel_H-E

Have you gave the extension for UiPath in edge browser.

Open edge browser → click on 3 dots on top right corner → open extension option → give the extension to UiPath.

If you are getting any error then send the screenshot of it.

Hope it helps!!

@Daniel_H-E

  1. Is this occuring on robots only? Or when running from studio also?
  2. If studio also can you try opening the locas pane and check exception details please
  3. When the edge is launched can you check before closing if the extrnsion is opened or if is not visible?
  4. Did you try checking event viewer logs for any suspicious activity

Cheers

Hi @Daniel_H-E

Try with updating all the dependencies available in the project.
Clear the browser cache

Hope it helps!!

Hi, we’ve been having the same problem since yesterday.
If Edge browser is opened in an anonymous window, Chrome Native Messaging does not start.
If I open a new standard window at the same time as the anonymous window, the robot starts working in the anonymous window.
There are some changes in the new browser version: Microsoft Edge release notes for Stable Channel | Microsoft Learn

Thank you for any recommendations on how to resolve the issues.

1 Like

I’ve the same issue, non of the standard solutions work. Tried reinstalling the extension, clearing whole browser, creating new profile. Error: Edge: Could not communicate with the UiPath extension for browser ‘msedge.exe’. Please make sure the extension is installed and enabled.

  1. I experience this issue in the robot and running from studio.
  2. Stops running the job and give the error Edge: Could not communicate with the UiPath extension for browser ‘msedge.exe’. Please make sure the extension is installed and enabled.
  3. Extension is visible and running without errors
  4. Error log:

UiPath.Executor 23.4.1.0
System.NullReferenceException: Object reference not set to an instance of an object.
at UiPath.UIAutomationNext.Services.SearchService.GetComputerVisionMatchesAsync(ISearchCVRequest request, TimeoutToken timeoutToken)
at UiPath.UIAutomationNext.Services.TargetServiceBase.GetMatchesBySingleSearchStepTask(ITarget target, TargetSearchSteps step, ISearchCache cache, IUiNodeX parentNode, TimeoutToken token)
at UiPath.UIAutomationNext.Services.TargetServiceBase.GetMatchesByTargetStep(ITarget target, TargetSearchSteps step, ISearchCache cache, IUiNodeX window, TimeoutToken token)
at UiPath.UIAutomationNext.Services.TargetFindService.FindMatchesParallelAsync(FindMatchesRequest request, ISearchCache cache, IUiNodeX window, TimeoutToken token)

and


UiPath.Executor 23.4.1.0
UiPath.UIAutomationNext.Exceptions.ApplicationOpenException: Could not communicate with the UiPath extension for browser ‘msedge.exe’. Please make sure the extension is installed and enabled.

We are having the same issue as well where Chrome Native Messaging does not start when opening Edge in InPrivate mode. We have tried all the standard troubleshooting steps including updating packages to their latest versions. The current workaround we have is to open a normal Edge browser follow by InPrivate Edge browser and closing the normal Edge browser.

Hey @Daniel_H-E

A. Before processing the In Private window, add processing to launch Edge (normal mode instead of In Private window) by the “Open Browser” or “Use Application/Browser” activity.
“ChromeNativeMessagingHost.exe” will automatically start when you open the Edge browser (normal mode, not the In Private window), so you can get the elements of the In Private window from Studio/Robot.
The disadvantage of this method is that it requires changes to the automation project.

B. Set the “Incognito/Private Window” option in the “Use Application/Browser” activity to False and use “CustomFolder” in “User Data Folder Mode” instead of this option.
Information such as cookies can be cleared by deleting the custom folder.
The disadvantage of this method is that it requires changes to the automation project.

C. Install UiPath MV2 extension.
It can be installed by adding the extension ID “hmpkmolbbcopahpbplbdaapacncbbc” to the ExtensionInstallForcelist group policy.
The advantage of this method is that no changes to the automation project are required.
The disadvantage of this method is that the user must manually enable the “Allow in InPrivate” option in UiPath’s browser extension.

D. Downgrade your Edge browser to version 114.

For more information , refer below thread

Hope it helps you

1 Like

The extension ID “hmpkmolbbcopahpbplbdaapacncbbc” doesn’t exist

Same probleme here - since Saturday July-22 :frowning:

1 Like

Yep same here. I solved the problem for now to manually start Edge in normal mode, and after that a second edge in private mode. Then it’s working…

Problem is caused by the ‘Chrome Native Messaging Host’ that won’t start if you run edge in private mode. So running normal edge before causes this process to start and then your second browser inprivate works. See also the topic: The robots couldn’t communicate with Private mode of MS Edge browser - Help / Studio - UiPath Community Forum

1 Like

Hello,

With the new Edge update, looks like “Chrome Native Messaging Host (32 bit)” service is unable to kick off when launched In-Private mode.

As a work around, I have included my Edge In-private Use browser activities within a regular Edge use browser activity. This works for me.

Hope that helps you out!

image

1 Like

Hi @rlgandu

Here are the results:

  1. Reinstalling will probably fix this issue and have tried to reinstall
  2. As said above have tried to reinstall but issue still continues.
  3. Have checked with our security team they have told us the firewall isn’t blocking the Extension. They have said UiPath tries to communicate with the Extension but it cannot find it.
  4. Cleared browsewr data and issue still exists
  5. Permissions as per my screenshots above should allow UiPath to work with an in-private webpage.
  6. Dependencies are all up-to-date none of them require any update.
  7. Have yet to try this but will try exhaust all other alternatives first.

Sorry I don’t quite follow how i give the extension to UiPath

This has also worked for me I added this activity before the in-private browser activities:

@Daniel_H-E

Open the browser application that you want to use for automation if it is chrome application.
Open the chrome application manually and at the top right corner you find the three dots hit on three dots → select the extensions → Then select the UiPath extension → if you are not given the extension to UiPath provide the extension and try.

Hope you understand!!

Thanks for your reply. I think the issue has been figured out. Looks like its an issue where if Edge is launched in ‘in-private’ the ‘Chrome Native Messaging Host’ doesn’t launch.
image
This application is needed for UiPath to communicate with Edge.

The work around for now seems like:

  1. Open a normal instance of Edge first to have ‘Chrome Native Messaging Host’ start up, and
  2. Then to launch another instance of Edge in-private mode. This solution allows UiPath to work with Edge in-private mode.

During the weekend MS Edge browser was automatically updated to 115.0.1901.183 version which causes issues with ‘in-private’ mode. At least in our team, we identified how to solve this issue (requires Admin rights):

  1. Uninstall MS Edge 115 build from all virtual machines.
  2. Install MS Edge 114 build (download the latest stable 114 package from here here
  3. Rename the ‘MicrosoftEdgeUpdate.exe’ file in ‘C:\Program Files (x86)\Microsoft\EdgeUpdate’ (this will stop automatic updates)
  4. Install UiPath Extension for MS Edge with the ‘Current User’ option
  5. Enable the extension by opening MS Edge
  6. Uninstall UiPath Extension for MS Edge
  7. Install the extension once again with the ‘Group Policy Offline’ option
  8. Enable the extension by opening MS Edge

Maybe it’s not an ideal solution, but it worked for us at least temporarily while we’re waiting for official information on how to solve this issue.

For us, we were experiencing a similar issue, but it was due to LastPass extension interfering with the UiPath extension. I would check any other extensions in your browser and disable/uninstall them and retest.

Hi everyone,

Please refer to this UiPath forum post for available workarounds:

Today we added an update there regarding a workaround we implemented in UiPath.UIAutomation.Activities package version 23.8.0-preview.

You can further check that forum post for updates on this issue.

Regards,
Luiza