Edge - "Cannot communicate with browser"

Hey all,

Recently we have come across this error when using the edge browser. Our processes have been working fine and this has just randomly started occurring. It only happens to some queue items though, meaning that it seems to only happen 30~ of the time. I have tried uninstalling and reinstall the edge extension and updating packages with no luck.

Also, can confirm the browser is open – our error screenshot shows the browser is actually open.

Edge Application/Browser Properties:

Hi @David_Hernandez2
please try with upgrage/downgrade UI Automation package

Recently I faced same issue and I solved it by upgrading downgrading package.

Do you know what version you got it to work at?

@David_Hernandez2 Yes I can share. Let me check

1 Like

@David_Hernandez2 Yes Please Try This one

1 Like

After I do this change and try to open my workflow, I get an “invalid” workflow error.

@David_Hernandez2 Do you upgrade it or downgrade?

Downgraded it. Currently on the newest version 20.10.5

@David_Hernandez2 so try to upgrade maximum latest one

1 Like


Doesn’t seem to have fix the issue sadly, regardless of dependency version.

@David_Hernandez2 are you facing issue in attach browser activity? right.
please show me exact activity. I

Uninstalling edge and reinstalling seemed to fix the issue.

@David_Hernandez2 do you able to run it now?

Yep, it just ran through all queue items with no issue after reinstalling edge browser.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.