Dynamic SQL generation is not supported against a SelectCommand that does not return any base table information

datatable
database
studio
query

#1

Hello ! :slight_smile:

I know it might be ralated to this , But even if I don’t assing a primary key throws the same error. IDK if this is uipath related, well, does any one faced this in the past. I am attaching the files, thanks.

Insert_fuelUsageDT.zip (700.4 KB)

I’m trying to insert the datatable into a mdb


#2

Does your spreadsheet works with current version of Excel Activities?


#3

Hi Vvaidya, yes, i have conducted test like read range, write cell, append range. and writing the output in another excel file.


#4

Hi,

I had the same error.
My process looked as follows:

  1. connect to DB
  2. select query from table
  3. disconnect from DB
  4. connect to DB
  5. insert into DB table
  6. disconnect from DB

I solved it by removing the first disconnect and the second connect activities.
The process looks as follows now:

  1. connect to DB
  2. select query from table
  3. insert into DB table
  4. disconnect from DB

Hope it helps people with the same issue :slight_smile:


#5

Hello,

I found the error but sorry never came back to post it, it has to do with the headers.but the connection fix you are posting might help, I mark your answer as solution, thanks buddy.

regards.


#6

Could you send the right program, when putting the headers, it gives me another error.