Dynamic selector not working, even passing wild chars

Hello All,

I’m using Studio LTS vr 2019.10.1 and facing some strange selector problem the details are below:

Issue/observations
Valid type into selector is unable to type and not even throwing error
case 1. below (Original selector, validation sucess and highliting as well)
"
but issue is after replacing dynamic char 4 to * from above selector, it still validated but not highliting below
Case 2.
"
Case 3. Most Strange part is after replacing dynamic part “4” to “3” it’s validated but not highliting
"

What i have tried:

  1. kept type into activity inside attach browser
  2. Replaced dynamic part to wild char “*”
    “”
  3. identifies static field values and kept in selector
    “”
  4. also tried Anchor element below.

Any Help will be much appreciated

Many Thanks
Aditya




Hi!

Sometimes selectors will not be validated but this will works fine in run time. Have you checked this in run time or in debug mode. if not could you please try it once.

When you replace the selectors with wild card that should be validate and should highlighted. could you please check inside the UiExplorer for more alternative options

Regards,
NaNi

Hi @aditya.prakash ,

The Selectors are not visible, please use the Preformatted Text </> to enter the Selectors

Thanks @THIRU_NANI for suggestions, but i have already tried It’s not running while runtime

Hi!

Could we try with anchor base activity! inside the anchor (Find Element) and inside the Action (TypeInTo) and open the type in to in UiExplorer and choose the inner or outer text or aaname

Regards,
NaNi

Thanks @supermanPunch, i have added SS of selectors in explorer instead

Hey!,

you can either use Anchor base activity, or use indicate anchor while creating a valid selector.

Yes, i have tried with anchor base activity as well, but no luck!

Hi!

Instead of id can we try with aaname?

Regards,
NaNi

Yes, tried with aaname seprately, but not worked, also tried with other selector attributes but no luck!!

Hey!,

maybe this link will assist you in making a valid selector: About Selectors

also, could you please try using indicate anchor.

Hi Osho, I have tried these all work arounds

The main unusual thing i observed is below all three selectors are valid and dynamic part in bold is accepting more than one value, out of them one is working fine, that’s why wild char is not working in this scenario!!
< “” />
< “” />
< “” />